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1.Installation 

1.1 Software Installation 

1.1.1 Installation Steps 

① Double-click the software installation package to pop up the software installation i

nterface. 

 

Installation Interface 

② Set the installation path (usually keep the default), check the box "I agree to the l
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icense terms and conditions", and then click "Install". 

 

 Set Installation Path 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

7 

 

Waiting for Installation 

③ After waiting for the program installation process to end, the License Manager ins

tallation interface will pop up. 
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License Manager Installation Interface 

④  Set the installation path (usually keep the default), check the box "I agree to the 

license terms and conditions", then click "INSTALL" and wait for the program ins

tallation process to complete. 
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Set installation path 

⑤ After the License Manager is installed, click the "Finish" button to close the Lice

nse Manager installation interface. 
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 License Manager Installation Completed 

⑥ The CoProcess software installation is completed. Click the "Finish" button to clos

e the software installation interface. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

11 

 

 Software Installation Completed 

Note： 

When installing, it is recommended to close antivirus software to prevent the installati

on process from being interrupted by the antivirus software. 

 

1.1.2 Installation Environment 

Memory: Minimum 16GB, recommended 64GB and above. 

Central Processor (CPU): Minimum Intel Core i7-7700, recommended Intel Core i9- 

10900K and above. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

12 

Graphics processing unit (GPU): video memory is not less than 4GB, minimum NVI

DIA GeForce 1050 Ti, recommended 3060 series or more, AMD graphics card is not 

supported. 

Operating systems: win10 (64-bit), win11 (64-bit). 

 

1.1.3 Software Uninstallation 

① Open the "Start" menu on your computer, find the "CoProcess 2025" folder, and c

lick "Uninstall CoProcess 2025". 

 

Figure: CoProcess in Start Menu 

② In the pop-up dialog box, click "Yes" to complete the software uninstallation. 

 

Figure: Uninstall Confirmation 

 

  



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

13 

2.Introduction to Software Functions 

2.1 Software Window 

2.1.1 Toolbar in the 3D View 

Function description: 

In the 3D view, there are two sets of toolbars, horizontal and vertical, and they are b

oth in the upper right area of the 3D view window. 

The functions in the horizontal toolbar, from left to right, are point cloud rendering, p

oint size setting, opacity setting, point cloud rendering settings, model wireframe rende

ring, model texture rendering, and model wireframe-only rendering. 

The functions in the vertical toolbar, from top to bottom, are view angle, view directi

on, center display, and view lock.   

 

Toolbar in the 3D View 

 

 

2.1.1.1 Point Cloud Rendering 
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This section mainly introduces the point cloud rendering in the 3D view. Point cloud 

rendering can render point clouds in different ways, enabling users to obtain the requi

red information from different renderings. It mainly includes elevation rendering, intens

ity rendering, classfication rendering, RGB rendering, blend rendering, and other render

ing methods. The other rendering methods include return rendering, return number ren

dering, time rendering, single color rendering, scan angle rendering, scan direction ren

dering, source ID rendering, and user data rendering. 

 

 Point cloud rendering method  

Note: 

This function is only effective for point cloud data, and the default rendering method 

is elevation rendering. 
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2.1.1.1.1 Elevation Rendering 

Function description: 

Map the point cloud data to a specified color range based on its elevation values, wh

ich facilitates the observation of elevation changes in the point cloud data. 

Operation steps: 

① Click on the toolbar in the 3D view -> Point Cloud Rendering -> Color by elevat

ion 

 

Elevation Rendering Mode 
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 Elevation Rendering  

② Click on the Rendering Settings. As shown in the figure below, you can select dif

ferent color bars to modify the rendering effect. You can also modify the maximu

m and minimum values of the elevation range by adjusting the scroll bar, scrollin

g the mouse wheel, or entering numbers, and then you can modify the elevation r

endering effect in real time. The "Reset" option is used to restore the default valu

es.  

 

 Elevation Rendering Settings 

Note: 

This function is only effective for point cloud data containing elevation information. 

 

2.1.1.1.2 Intensity Rendering 

Function description: 

Map the intensity values of the point cloud data to a color range. 

Operation steps: 

① Click on the toolbar in the 3D view -> Point Cloud Rendering -> Color by intensi

ty. 
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Intensity Rendering Mode 

 

Intensity Rendering 

① Click on the Rendering Settings. As shown in the figure below, you can select diff

erent color bars to modify the rendering effect. Move the scroll bar, scroll the mouse 

wheel, or enter numbers to modify the maximum and minimum values of the intensity

 range, and you can view the intensity rendering effect in real time. The "Reset" butt

on is used to restore the default values.  
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Intensity Rendering Settings 

Note: 

This function is only effective for point cloud data containing intensity information. 

2.1.1.1.3 Classification Rendering 

Function description: 

Map each classification to a distinct color value based on different categories, enablin

g intuitive differentiation of point cloud data. 

Operation steps: 

① Click on the toolbar in the 3D view -> Point Cloud Rendering -> Color by classi

fication. 

 
 Classification Rendering Mode 
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Classification Rendering 

 

② Click on Rendering Settings. As shown in the figure below, the default setting is t

o render all categories. Uncheck the Select All checkbox to cancel the rendering di

splay of all categories. Uncheck the checkbox of a specific category to cancel its 

display. 

 
 Classification Settings  

③  Click the color on the right side of a classification to load the color list. You ca

n select basic colors, and it also supports capturing screen colors. Pick a color in 

the right-side color mapping table and click OK to modify the rendering color of t

he classification. 
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 Classification Color Settings 

Note: 

This function is only effective for point cloud data containing classification informatio

n. 

2.1.1.1.4 RGB Rendering 

Function description: 

Display point cloud data using its color attributes (RGB values). 

Operation steps: 

① Click on the toolbar in the 3D view -> Point Cloud Rendering -> Color by RGB. 
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 RGB Rendering Mode 

② The point cloud data in the view is rendered and displayed according to its own 

RGB color value, as shown in the following figure: 

 
 RGB Coloring Rendering 

Note: 

This function is only effective for point cloud data containing RGB information. 

2.1.1.1.5 Blend Rendering 

Function description: 
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This function enables mixed rendering of point cloud data by mapping its elevation a

nd intensity attributes to uniformly varying color intervals. It shows the combined effe

cts of elevation and intensity changes, facilitating clear distinction of feature boundarie

s. 

Operation steps: 

①  Click on 3D View Toolbar -> Point Cloud Rendering -> Color by blending 

 

Blend Rendering Mode 

②  After selecting the color bar, the point cloud after blending rendering will display

 in the view. 
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 Blending Rendering  

③ Click Rendering Settings. As shown in the figure below, move the scroll bar, scrol

l the wheel, or input numbers to modify the maximum and minimum values of el

evation and intensity, and view the blended rendering effect in real time. Reset is u

sed to restore default values. 

 

Blending Rendering Settings 
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2.1.1.1.6 Echo Number Rendering 

Function description: 

Render point clouds in different colors based on their echo number attributes to facilit

ate intuitive differentiation of point cloud data with varying echo counts. 

Operation steps: 

① Click 3D View → Point Cloud Rendering → Other → Number of Returns in the tool

bar to view the rendering results classified by different echo numbers. 

 
Echo Rendering Mode 
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Echo Rendering  

② Click Rendering Settings. As shown below, all echo numbers are rendered by defa

ult. Uncheck the Select All checkbox to disable rendering for all echo numbers. Un

check a specific echo number checkbox to hide only that echo number. 

 

Echo Rendering Settings 

③ Click the color swatch next to an echo number to open the color picker. You can: 

 Select a basic color. 

 Capture a screen color via clicking anywhere on the screen.  

 Pick a color from the right-side color table. 

 Click OK to modify the rendering color for the echo. 
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Echo Number Settings 

Note: 

This function is only effective for point cloud data containing echo information. 

2.1.1.1.7 Echo Sequence Number Rendering 

Function description: 

Render point clouds in distinct colors based on their echo sequence number attributes 

to quickly visualize the rendering effects of different echo sequences. 

Operation steps: 

① Click on the toolbar in the 3D view -> Point Cloud Rendering -> Other -> Retur

n Number, and you can view the echo number rendering of the point cloud. 
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Echo Sequence Number Rendering Mode 

 

Echo Sequence Number Rendering 

② Click Rendering Settings. As shown below, all echo sequence numbers are rendere
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d by default. Uncheck the Select All checkbox to disable rendering for all sequenc

es. Uncheck a specific echo sequence number checkbox to hide only that sequenc

e. 

 

Echo Sequence Rendering Settings 

③ Click the color swatch next to an echo number to open the color picker. You can: 

 Select a basic color. 

 Capture a screen color via clicking anywhere on the screen.  

 Pick a color from the right-side color table. 

 Click OK to modify the rendering color for the echo. 
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Set Echo Sequence Number Colors 

Note: 

This function is only effective for point cloud data containing echo sequence number i

nformation. 

2.1.1.1.8 Time Rendering 

Function description: 

Render the point cloud with different color values according to the acquisition time. 

Operation steps: 

① Click 3D View Toolbar -> Point Cloud Rendering -> Other -> Time to view the t

ime rendering effect. 

 

 

Figure: Time Rendering Function Entry 
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Figure: Time Rendering Effect 

 

Figure: Time Rendering Settings 

2.1.1.1.9 Single Rendering 

Function Description: 

Map point cloud data from different point cloud files to different color values, facilita

ting intuitive differentiation of point cloud data from different segments. 
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Operation Steps: 

① Click 3D View Toolbar -> Point Cloud Rendering -> Other -> Single Color to vie

w the monochromatic rendering effect. 

 

 

Figure: Single Color Rendering Function Entry 
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Figure: Single Color Rendering Effect 

 

2.1.1.1.10 Scan Angle Rendering 

Function Description: 

Map the scan angle attribute to uniformly varying color values based on different scan

 angle values of the point cloud data. 

Operation Steps: 

① Click 3D View Toolbar -> Point Cloud Rendering -> Other -> Scan Angle to vie

w the scan angle rendering effect; 

 

Figure: Scan Angle Rendering Function Entry 
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Figure: Scan Angle Rendering 

② Select different color strips in the color strip as needed; click Rendering Settings, 

drag the scroll bar or scroll the wheel to modify the maximum and minimum val

ues of the scan angle range, and you can view the scan angle rendering effect in 

real time. Reset is used to restore the default values. 
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Figure: Scan Angle Rendering Settings 

2.1.1.1.11 Scan Direction Rendering 

Function Description: 

Map the scan direction values to uniformly varying color values based on different sc

an directions of the point cloud data. 

Operation Steps: 

① Click 3D View Toolbar -> Point Cloud Rendering -> Other -> Scan Direction to 

view the scan direction rendering effect. 
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Figure: Scan Direction Rendering Function Entry 

 
Figure: Scan Direction Rendering 

② Select different color strips in the color strip as needed; click Rendering Settings, 

drag the scroll bar or scroll the wheel to modify the maximum and minimum val

ues of the scan direction range, and you can view the scan direction rendering eff

ect in real time. Reset is used to restore the default values. 
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Figure: Scan Direction Rendering Settings 

2.1.1.1.12 Source ID Rendering 

Function Description: 

Map the source ID attribute to uniformly varying color values based on different sour

ce ID values of the point cloud data. 

Operation Steps: 

① Click 3D View Toolbar -> Point Cloud Rendering -> Other -> Source ID to view 

the source ID rendering effect. 
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Figure: Source ID Rendering Function Entry 

 

Figure: Source ID Rendering Effect 

② Select different color strips in the color strip as needed; click Rendering Settings, 

drag the scroll bar or scroll the wheel to modify the maximum and minimum val

ues of the source ID range, and you can view the source ID rendering effect in r

eal time. Reset is used to restore the default values. 
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Figure: Source ID Rendering Effect 

2.1.1.2 Point Size 

Function Description: 

Adjust the size of point objects in the point cloud data in the view. 

Operation Steps: 

Click 3D View Toolbar -> Set Point Size, scroll the mouse wheel, scroll up to increa

se the point size, scroll down to decrease the point size, or directly enter the point si

ze value to change the point size. The point size adjustment effect is displayed in the

 view window in real time. 

 

Figure: Point Size Settings 
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Figure: Point Size 3 

 

Figure: Point Size 1 

Note: The point size setting range is 1-10, and it only takes effect for point objects i

n the point cloud data. 

 

2.1.1.3 Opacity Setting 
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Function Description: 

Adjust the opacity of the point cloud data in the view. 

Operation Steps: 

Click 3D View Toolbar -> Opacity Setting, scroll the mouse wheel, scroll up to incre

ase the point cloud opacity, scroll down to decrease the point cloud opacity, or directl

y enter the opacity value to change the point cloud opacity. The adjustment effect is 

displayed in the view window in real time. 

 

Figure: Opacity Settings 

 

Figure: Opacity 100% 
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Figure: Opacity 50% 
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Figure: Opacity 20% 

Note: The opacity setting range is 0-100, and it only takes effect for point cloud dat

a. 

2.1.1.4 Wireframe Rendering 

Function Description: 

Switch for wireframe display of OSGB model data in the view. 

Operation Steps: 

Click 3D View Toolbar -> Wireframe to switch the display and closing of the wireframe, which 

is closed by default. 

 

Figure: 3D View Wireframe Rendering 

2.1.1.5 Texture Rendering 

Function Description: 

Switch for texture display of OSGB model data in the view. 

Operation Steps: 

Click 3D View Toolbar -> Texture to switch the display and closing of the texture, w
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hich is open by default. 

 

Figure: Enable Texture Rendering 

 

Figure: Disable Texture Rendering 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

44 

2.1.1.6 Wireframe-Only Rendering 

Function Description: 

Switch for wireframe-only rendering mode of OSGB model in the view. 

Operation Steps: 

Click 3D View Toolbar -> Wireframe Only to switch the display and closing of the 

wireframe-only mode, which is closed by default. When   the wireframe-only mode is

 enabled, the model only displays the wireframe part. 

 

Figure: 3D View Wireframe-Only Rendering 

Note: After enabling wireframe-only rendering, the wireframe and texture rendering bu

ttons are grayed out. You can set wireframe and texture rendering only after exiting t

he wireframe-only rendering mode. 

2.1.1.7 Real-Time Coordinate Axis 

Function Description: 

Real-time display of the direction of the 3D view, with the Z-axis as the vertical upw

ard direction; the X-axis as the east direction, and the Y-axis as the north direction. 

Operation Steps: 
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The real-time 3D coordinate axis are always displayed in the lower right corner of th

e 3D view. 

 

Figure: 3D Real-Time Coordinate Axis 

2.1.1.8 View Angle 

Define the projection mode of the data in the view, including orthographic, perspectiv

e, and 2D. 

 

Figure: View Angle Function Entry 
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2.1.1.8.1 3D View 

In 3D view, the projection mode of objects in the view is orthographic project

ion. Orthographic projection, also known as parallel projection, ensures that the 

size and dimensions of the object remain unchanged after projection, regardless 

of how far the object is from the camera. 

 

Figure: 3D View 

 

2.1.1.8.2 2D View 

2D projection uses 2D projection to view objects, projecting the object onto th

e XY plane, displaying a top-down effect, and locking the Z-axis direction vert

ically upward. 
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Figure: 2D Projection 

 

2.1.1.9 View Direction 

This section introduces the view direction. Click to select the view direction, and the 

data in the view can present six different direction perspectives: front view, back vie

w, left view, right view, top view, and bottom view. 

 

Figure: View Direction 
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Figure: Top View 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

49 

 

Figure: Bottom View 

 

Figure: Front View 
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Figure: Back View 

 

Figure: Left View 
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Figure: Right View 

 

2.1.1.10 Center Display 

Function Description: 

Use the maximum zoom ratio to fully display the bounding box range of all data in t

he display state in the view. 

Operation Steps: 

① For data after executing zoom in, zoom out, or pan commands, click 3D View To

olbar -> Center Display; 

② Vector, point cloud, DEM, image, and OSGB model data will be scaled according 

to the proportion of the view border and moved to the center of the view windo

w for display. 
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Figure: Comparison Before and After Centering 

2.1.1.11 Pan 

Pan the data in the view. Press and hold the right mouse button to drag and pan the 

objects in the view. 

2.1.1.12 Rotate 

Rotate the data in the view. Press and hold the left mouse button to drag and rotate t

he objects in the view. 

2.1.1.13Zoom In 

Enlarge the display of data in the view. Scroll the mouse wheel upward to zoom in o

n the data. 

2.1.1.14Zoom Out 

Reduce the display of data in the view. Scroll the mouse wheel downward to zoom o

ut on the data. 

2.1.1.15 View Lock 

View lock can lock the pan, rotate, and zoom functions of the view. 
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Figure: Lock View 

 

2.1.1.15.1 Lock Pan 

Activate the lock pan function, and the data objects in the view cannot be panned. 

 

2.1.1.15.2 Lock Rotate 

Activate the lock rotate function, and the data objects in the view cannot be rotated. 

 

2.1.1.15.3 Lock Zoom 

Activate the lock zoom function, and the data objects in the view cannot be zoomed. 

2.1.2 Toolbar of facade View 

Function Description: 

There are two sets of horizontal and vertical toolbars in the façade view toolbar, fixed

 in the upper right area of the facade view window. The functions in the horizontal t

oolbar from left to right are switch facade view, facade parameter setting, Vector unfo

lding, facade export, point cloud rendering mode, point size setting, opacity setting, po

int cloud rendering setting, model wireframe rendering, model texture rendering, and 

model wireframe-only rendering. The functions in the vertical toolbar from top to bott

om are center display and view lock. 
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Figure: Toolbar in the Elevation View 

Operation Steps: 

Left-click the buttons in the toolbar to implement the corresponding functions. 

2.1.2.1 Swtich Facade 

Function Description: 

Switch elevation perspectives. 

Operation Steps: 

① When the current facade view is a four-view, click the first button in the horizont

al toolbar of the facade view, and click "Front, Left, Back, Right" in the drop-do

wn box to switch the display of point cloud and vector data in different directions

 of the facade view. 

 

Figure: Elevation Switch - Four-View 
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Figure: Elevation View - Four-View 

② When the current facade view is a front view, click the first button in the horizon

tal toolbar of the facade view, and click different numbers in the drop-down box t

o switch the display of point cloud and vector data on different sides of the facad

e view. 

 

Figure：facade Switch - Front View 
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Figure: Elevation View - Front View 

 

2.1.2.2 Facade Parameter Setting 

Function Description: 

Set the thickness, and expansion of the current facade. 

Operation Steps: 

① Click the facade parameter setting button to pop up a dialog box. You can modify

 the parameter values by entering numbers, scrolling the wheel, or clicking the up

 and down arrow buttons. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

57 

 

Figure: Facade Parameter Setting 

 

Figure: Facade Parameter Setting Dialog Box 

Front Width (m): The width of the facade proxy line in the 3D view from the cente

r line outward (the facade proxy line in the front view is to the right) when viewed 

from the top. The default value is 1.5m, and the setting range is [0.001, 100]. After 

modification, the data in the facade view is displayed as the range covered by the fac

ade proxy line in the 3D view when viewed from the top. 

 

Figure: Front Width 1.5m 

 

Figure: Front Width 3m 

Back Width (m): The width of the facade proxy line in the 3D view from the center

 line inward (the facade proxy line in the front view is to the left) when viewed fro

m the top. The default value is 1.5m, and the setting range is [0.001, 100]. After mo
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dification, the data in the facade view is displayed as the range covered by the façad

e proxy line in the 3D view when viewed from the top. 

 

Figure: Back Width 1.5m 

 

Figure: Back Width 1m 

Extend (m): The width of the facade proxy line expanded outward at both ends along

 the center line. The default value is 0m, and the setting range is [0, 100]. After mo

dification, the data in the facade view is displayed as the range covered by the facad

e proxy line in the 3D view when viewed from the top. 

 

Figure: Expansion 0m 
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Figure: Expansion 2m 

2.1.2.3 Vector Unfolding 

Function Description: 

Unfold the vector features of adjacent facades and display them in the current facade 

view. 

Operation Steps: 

Left-click the vector unfolding button in the toolbar of the facade view to switch bet

ween open and closed states (highlighted state is open, non-highlighted state is closed) 

 

Figure: Vector Unfolding 

The vertical height of the unfolded facade is determined by the bounding box height 

of the total data in the software, the width of the vector unfolding is determined by t

he length of the adjacent facade proxy line, and the unfolded vector can only be snap

ped and cannot be edited. 
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Figure: Vector Unfolding 

 

2.1.2.4 Facade Export 

Function Description: 

Facede export solves the problem that high-performance computers are required to sup

port due to the large amount of data when drawing plane and facade based on point 

cloud data. It can export the point cloud in the created facade in the format of ortho

photo or point cloud. When selecting orthophoto, the exported facade includes orthoph

oto, coordinate file with the same name, dxf and dwg files with the same name. 

Operation Steps: 

① Left-click the facade export button in the toolbar of the facade view to pop up th

e facade export dialog box. 
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Figure: Facade Export 

 

Figure: Facade Export Dialog Box 

② In the facade export dialog box, you can select the objects to be exported, which 

are current facade and all facades. When selecting the current facade, you need to

 name the exported file and select the export path; when selecting all facades, yo

u only need to select the export path and do not need to set the export name. 

 

Figure: Current Facade Path Selection Dialog Box 
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Figure: All Facades Path Selection Dialog Box 

③ In the facade export interface, set the type of data to be exported, which is divide

d into orthophoto and point cloud; when exporting orthophoto, export the orthopho

to consistent with the actual size of the point cloud according to the set resolutio

n, the resolution range supports 0.001-1, and generate orthophoto, coordinate file, 

dxf and dwg files in the selected export path; when exporting point cloud, the su

pported point cloud types are hpc, las1.2, las1.3, las1.4. 

 

Export Options: 

Type: Set the data format to be exported, which includes orthophoto orpoint cloud. 

 

Resolution: Set the resolution when exporting orthophoto. The value represents the sid

e length of the area occupied by one pixel in the orthophoto (unit: meter; the smaller 

the value, the more detailed the orthophoto, and the longer the export time). 

 

Format: Select the format of the exported point cloud, which can be hpc, las1.2, las

1.3, las1.4. 

 

Current Facade: Only the current facade is exported. 
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All Facades: All facades in the current proxy line are exported. 

2.1.2.5 Point Cloud Rendering Mode 

This section mainly introduces different point cloud rendering mode in the facade vie

w. Point cloud rendering can render point clouds in different ways, facilitating users t

o obtain the required information from different renderings. It mainly includes depth r

endering, elevation rendering, intensity rendering, classification rendering, RGB renderi

ng, blend rendering, and other rendering methods. 

 

 

Figure: Point Cloud Rendering mode in the Facade View 

Note: This function is only effective for point cloud data, and the default rendering is

 depth rendering. 

2.1.2.5.1 Depth Rendering 

Function Description: 

Map point clouds at different depths to a specified color interval according to the dep
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th of the point cloud data. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Depth to display the dep

th rendering effect of the data; 

 

Figure: Depth Rendering Function Entry 

 

Figure: Depth Rendering 

② Click Point Cloud Coloring Settings. As shown in the figure below, you can selec

t different color strips to modify the rendering effect, and also modify the maximu

m and minimum values of the rendering depth range by dragging the scroll bar, s

crolling the wheel, or entering numbers to modify the depth rendering effect in re

al time. Click the reset button in the lower right corner to restore the default valu

es. 
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Figure: Depth Rendering Settings 

2.1.2.5.2 Elevation Rendering 

Function Description: 

Map the point cloud data to a specified color interval according to its elevation value,

 facilitating the observation of elevation changes in the point cloud data. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Elevation to display the 

elevation rendering effect of the data; 

 

 

Figure: Elevation Rendering 
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② Click Rendering Settings. As shown in the figure below, you can select different c

olor strips to modify the rendering style, and modify the maximum and minimum 

values of the elevation by dragging the scroll bar, scrolling the wheel, or entering 

numbers to modify the elevation rendering effect in real time. Click the reset butt

on in the lower right corner to restore the default values. 

 

Figure: Elevation Rendering Settings 

Note: This function is only effective for point cloud data containing elevation informa

tion. 

2.1.2.5.3 Intensity Rendering 

Function Description: 

Map the intensity values of the point cloud data to uniformly varying color intervals. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Intensity to display the i

ntensity rendering effect of the data; 
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Figure: Intensity Rendering 

② Click Rendering Settings. As shown in the figure below, select different color strip

s to use different rendering styles; drag the scroll bar, scroll the wheel to modify 

the intensity value, or enter numbers to modify the maximum and minimum value

s of the intensity to view the intensity rendering effect in real time. Click the res

et button in the lower right corner to restore the default values. 

 

Figure: Intensity Rendering Settings 

 

Note: This function is only effective for point cloud data containing intensity informat

ion. 

2.1.2.5.4 Classification Rendering 

Function Description: 

Map categories to different color values according to different category attributes of th
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e point cloud data, facilitating intuitive differentiation of point cloud data of different 

categories. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Classification to view th

e rendering effect of category display; 

 

Figure: Classification Rendering 

 

② Click Rendering Settings. As shown in the figure below, all categories are rendere

d by default. Uncheck the Select All checkbox to cancel the rendering display of 

all categories. Uncheck the checkbox of a specific category to cancel the display 

of that category. 
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Figure: Classification Settings 

 

③ Click the color on the right side of a category to load the color list. You can sel

ect basic colors and also support obtaining screen colors. Pick a color in the color

 mapping table on the right and click OK to modify the classification rendering c

olor. 

 

Figure: Set Classification Color 
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Note: This function is only effective for point cloud data containing classification info

rmation. 

2.1.2.5.5 RGB Rendering 

Function Description: 

Display point clouds using the color attributes (RGB values) of the point cloud data. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> RGB; 

② The point cloud data in the view is rendered and displayed according to its own 

RGB color value, as shown in the following figure: 

 

Figure: True Color Rendering 

 

Note: This function is only effective for point cloud data containing RGB information. 

 

 

2.1.2.5.6 Blend Rendering 

Function Description: 

This function realizes the mixed rendering display of point cloud data, mapping the el

evation and intensity attributes of the point cloud data to uniformly varying color inte
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rvals, which can show the combined change effect of elevation and intensity, facilitati

ng clear distinction of ground object boundaries. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Blend to view the elevat

ion and intensity blend rendering effect; 

② After selecting the color strip, the point cloud after blend rendering will be displa

yed in the view. 

 

 

Figure: Blend Rendering 

 

③ Click Rendering Settings. As shown in the figure below, drag the scroll bar, scroll

 the wheel, or enter numbers to modify the elevation and intensity to change the 

maximum and minimum values of the elevation and intensity, and view the blend 

rendering effect in real time. Click the reset button in the lower right corner to re

store the default values. 
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Figure: Blend Rendering Settings 

2.1.2.5.7 Echo Number Rendering 

Function Description: 

Render point clouds with different color values according to their echo number attribut

es, facilitating intuitive differentiation of point cloud data with different echo numbers. 

Operation Steps: 

Click Facade View Toolbar -> Point Cloud Rendering -> Other -> Number of Returns

 to view the rendering results of data according to different echo numbers. 
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Figure: Number of Echo Rendering 

 

Figure: Echo Number Rendering Settings 

 

2.1.2.5.8 Echo Sequence Number Rendering 

Function Description: 

Render point clouds with different color values according to their echo sequence numb
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er attributes, quickly viewing the rendering effects of different echo sequences. 

Operation Steps: 

Click facade View Toolbar -> Point Cloud Rendering -> Other ->Return Number to vi

ew the echo sequence number rendering of the point cloud. 

 

Figure: Echo Sequence Number Rendering 

 

Figure: Echo Sequence Number Rendering Settings 

2.1.2.5.9 Time Rendering 

Function Description: 
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Render point clouds with different color values according to the acquisition time. 

Operation Steps: 

Click Facade View Toolbar -> Point Cloud Rendering -> Other -> Time to view the t

ime rendering effect. 

 

Figure: Time Rendering 
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Figure: Time Rendering 

2.1.2.5.10 Single Rendering 

Function Description: 

Map point cloud data from different point cloud files to different color values, facilita

ting intuitive differentiation of point cloud data from different segments. 

Operation Steps: 

Click Facade View Toolbar -> Point Cloud Rendering -> Other -> Single Color to vie

w the monochromatic rendering effect. 
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Figure: Single Color Rendering 

2.1.2.5.11 Scan Angle Rendering 

Function Description: 

Map the scan angle attribute to uniformly varying color values based on different scan

 angle values of the point cloud data. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Other -> Scan Angle to 

view the scan angle rendering effect; 
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Figure: Scan Angle Rendering 

 

② Select different color strips in the color strip as needed; click Rendering Settings, 

drag the scroll bar or scroll the wheel to modify the maximum and minimum val

ues of the scan angle range, and you can view the scan angle rendering effect in 

real time. Reset is used to restore the default values. 

 

 

Figure: Scan Angle Rendering Settings 

2.1.2.5.12 Scan Direction Rendering 

Function Description: 
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Map the scan direction values to uniformly varying color values based on different sc

an directions of the point cloud data. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Other -> Scan Direction 

to view the scan direction rendering effect; 

 

Figure: Scan Direction Rendering 

 

② Select different color strips in the color strip as needed; click Rendering Settings, 

drag the scroll bar or scroll the wheel to modify the maximum and minimum val

ues of the scan direction range, and you can view the scan direction rendering eff

ect in real time. Reset is used to restore the default values. 

 

Figure: Scan Direction Rendering Settings 
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2.1.2.5.13 Source ID Rendering 

Function Description: 

Map the source ID attribute to uniformly varying color values based on different sour

ce ID values of the point cloud data. 

Operation Steps: 

① Click Facade View Toolbar -> Point Cloud Rendering -> Other -> Source ID to v

iew the source ID rendering effect; 

 

Figure: Source ID Rendering 

 

② Select different color strips in the color strip as needed; click Rendering Settings, 

drag the scroll bar, scroll the wheel, or enter numbers to modify the maximum an

d minimum values of the source ID range, and you can view the source ID rende

ring effect in real time. Click the reset button in the lower right corner to restore 

the default values. 
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Figure: Source ID Rendering Settings 

2.1.2.6 Point Size 

Function Description: 

Adjust the size of point objects in the point cloud data in the view. 

Operation Steps: 

Click Facade View Toolbar -> Set Point Size, scroll the mouse wheel, scroll up to in

crease the point size, scroll down to decrease the point size, or directly enter the poin

t size value to change the point size. The point size adjustment effect is displayed in 

the view window in real time. 

 

Figure: Point Size Settings 
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Figure: Point Size is 3 

 

Figure: Point Size is 1 
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Note: The point size setting range is 1-10, and it only takes effect for point objects i

n the point cloud data. 

2.1.2.7 Opacity Setting 

Function Description: 

Adjust the opacity of the point cloud data in the view. 

Operation Steps: 

Click Facade View Toolbar -> Opacity Setting, scroll the mouse wheel, scroll up to i

ncrease the point cloud opacity, scroll down to decrease the point cloud opacity, or di

rectly enter the opacity value to change the point cloud opacity. The adjustment effect

 is displayed in the view window in real time. 

 

Figure: Opacity Settings 
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Figure: Opacity 100% 
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Figure: Opacity 50% 

 

Figure: Opacity 20% 

 

Note: The point size setting range is 0-100, and it only takes effect for point cloud d

ata. 

2.1.2.8 Wireframe Rendering 

Function Description: 

Switch for wireframe display of OSGB model data in the elevation view. 

Operation Steps: 

Click Facade View Toolbar -> Wireframe to switch the display and closing of the wir

eframe, which is closed by default. 
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Figure: Facade View Wireframe Rendering 

2.1.2.9 Texture Rendering 

Function Description: 

Switch for texture display of OSGB model data in the elevation view. 

Operation Steps: 

Click Elevation View Toolbar -> Texture to switch the display and closing of 

the wireframe, which is open by default. 

 

 

Figure: Enable Texture Rendering 
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Figure: Disable Texture Rendering 

2.1.2.10 Wireframe-Only Rendering 

Function Description: 

Switch for wireframe-only rendering mode of OSGB model in the elevation view. 

Operation Steps: 

Click Facade View Toolbar -> Wireframe Only to switch the display and closing of t

he wireframe-only mode, which is closed by default. When the wireframe-only mode i

s enabled, the model only displays the wireframe part. 

 

 

Figure: Facade View Wireframe Rendering 

Note: After enabling wireframe-only rendering, the wireframe and texture rendering bu
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ttons are grayed out. You can set wireframe and texture rendering only after exiting t

he wireframe-only rendering mode. 

2.1.2.11 Center Display 

Function Description: 

Use the maximum zoom ratio to fully display the bounding box range of all data in t

he display state in the view. 

Operation Steps: 

Click Facade View Toolbar -> Center to center the facade data in the view. 

 

 

Figure: Facade View Centering Effect 

2.1.2.12 View Lock 

View lock can lock the pan, rotate, and zoom functions of the view. 

 

Figure: Lock View 
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2.1.2.12.1 Lock Pan 

In the facade view, press and hold the right mouse button to drag and pan the object

s in the view.  

Activate the lock pan function, and the data objects in the view cannot be panned. 

2.1.2.12.2 Lock Rotate 

Objects in the facade view do not support rotation operations, rotation is locked by d

efault, and unlocking is not supported. 

2.1.2.12.3 Lock Zoom 

In the facade view, scrolling the mouse wheel upward enlarges the display of objects 

in the view, and scrolling the mouse wheel downward reduces the display of objects i

n the view. 

Activate the lock zoom function, and the data objects in the view cannot be zoomed. 

2.1.2.13 Real-Time 3D Coordinate Axis 

Display the direction of the current facade view, with the Y-axis as the vertical upwar

d direction; the X-axis as the horizontal direction, parallel to the proxy line of the cu

rrent facade; the Z-axis points to the user, indicating the positive direction of depth, a

nd the depth at the center line of the proxy line is 0. 

Operation Steps: 

After creating the facade view, the real-time coordinate axis of the facade view are di

splayed in the lower right corner. 

 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

90 

 

Figure: Facade Real-Time Coordinate Axis 

2.1.3 Snap 

The snap types supported by the software include: model snap, point cloudsnap, polar 

snap, endpoint snap, node snap, nearest point snap, intersection snap, midpoint snap, a

nd circle center snap, geometry center snap. 

 

Figure: Snap Status Bar 

2.1.3.1 Model Snap 

Function Description: 

When model snap is enabled, during vector drawing/editing/measurement, you can sna

p to the model near the mouse position. 

Operation Steps: 
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Click the model snap button in the status bar at the bottom right of the software. Wh

en the button is highlighted, it is in the enabled state. The software enables model sn

ap by default. When you do not need to snap to the model, click the button to cance

l the highlight to disable model snap. 

 

 

Figure: Model Snap Button 

 

Figure: Model Snap Style 

2.1.3.2 Point Cloud Snap 

Function Description: 

When point cloud snap is enabled, during vector drawing/editing/measurement, you can

 snap to the point cloud near the mouse position. 

Operation Steps: 

Click the point cloud snap button in the status bar at the bottom right of the softwar

e. When the button is highlighted, it is in the enabled state. The software enables poi

nt cloud snap by default. When you do not need to snap to the point cloud, click the

 button to cancel the highlight to disable point cloud snap. 

 

Figure: Point Cloud Snap Button 

 

Figure: Point Cloud Snap Style 
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2.1.3.3 Polar Snap 

Function Description: 

When polar snap is enabled, during vector drawing/editing/measurement, you can track 

and snap in the direction parallel to the X-axis or Y-axis. 

Operation Steps: 

Click the polar snap button in the status bar at the bottom right of the software. Whe

n the button is highlighted, it is in the enabled state. When you do not need polar sn

ap, click the button to cancel the highlight to disable polar snap. 

 

Figure: Polar Snap Button 

 

Figure: Polar Snap Style 

2.1.3.4 Endpoint Snap 

Function Description: 

When endpoint snap is enabled, during vector drawing/editing/measurement, you can s

nap to the endpoints or corner points of vector lines. 

Operation Steps: 

Click the endpoint snap button in the status bar at the bottom right of the software. 

When the button is highlighted, it is in the enabled state. The software enables endpo

int snap by default. When you do not need to snap to vector endpoints, click the butt

on to cancel the highlight to disable endpoint snap. 
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Figure: Endpoint Snap Button 

 

Figure: Endpoint Snap Style 

 

2.1.3.5 Node Snap 

Function Description: 

When node snap is enabled, during vector drawing/editing/measurement, you can snap 

to point objects. 

Operation Steps: 

Click the node snap button in the status bar at the bottom right of the software. Whe

n the button is highlighted, it is in the enabled state. The software enables node snap 

by default. When you do not need to snap to nodes, click the button to cancel the hi

ghlight to disable node snap. 

 

Figure: Node Snap Button 

 

Figure: Node Snap Style 

2.1.3.6 Nearest Point Snap 

Function Description: 

When nearest point snap is enabled, during vector drawing/editing/measurement, you c

an snap to the vector line near the mouse position. 

Operation Steps: 

Click the nearest point snap button in the status bar at the bottom right of the softwa

re. When the button is highlighted, it is in the enabled state. The software enables ne
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arest point snap by default. When you do not need to snap to the nearest point, click

 the button to cancel the highlight to disable nearest point snap. 

 

 

Figure: Intersection Snap Button 

 

Figure: Intersection Snap Style 

2.1.3.7 Intersection Snap 

Function Description: 

When intersection snapping is enabled, you can snap to the intersections of vector lin

es during vector drawing, editing, or measurement. 

Operation Steps: 

To enable intersection snapping, click the intersection snapping button in the bottom-ri

ght corner of the software's status bar. The button will highlight when activated. To d

isable it, simply click the button again to remove the highlight. 

 

Figure: Intersection Snap Button 

 

Figure: Intersection Snap Style 

 

2.1.3.8 Midpoint Snap 
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Function Description: 

When midpoint snap is enabled, during vector drawing/editing/measurement, it can sna

p to the midpoint of a vector line. 

 

Operation Steps: 

Click the midpoint snap button in the status bar at the bottom right of the software. 

The button is in the enabled state when highlighted. To disable vector midpoint snapp

ing, click the button to cancel the highlight. 

 

 

Figure: Midpoint Snap Button 

 

Figure: Midpoint Snap Style 

2.1.3.9 Circle Center Snap 

Function Description: 

When center snap is enabled, during vector drawing/editing/measurement, it can snap t

o the center of a circle or arc. 

Operation Steps: 

Click the center snap button in the status bar at the bottom right of the software. The

 button is in the enabled state when highlighted. To disable center snapping, click the 

button to cancel the highlight. 

 

Figure: Center Snap Button 
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Figure: Center Snap Style 

 

2.1.3.10 Snap Switch 

Function Description: 

Enables or disables the snap mode. The button is highlighted when the snap mode is 

enabled, and not highlighted when disabled. 

Operation Steps: 

Click the snap switch button in the status bar at the bottom right of the software. Th

e button is highlighted when the snap mode is enabled (the software enables snap by 

default). To disable all snap types, click the button to cancel the highlight. 

 

Figure: Snap Switch Button 

2.1.1.11 Snap Settings 

Function Description: 

In the snap settings dialog box, users can choose whether to enable the snap function 

and select snap types. 

Operation Steps: 

① Click the drop-down arrow button in the status bar at the bottom right of th

e software to pop up the snap panel. In the snap panel, you can also enable or disa

ble a specific snap type. 
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Figure: Snap Settings Button 

② Click the "Snap Settings" button in the panel to pop up the snap settings dia

log box. In the dialog box, users can choose whether to enable the snap function an

d select snap types: checking "Enable Object Snap" enables the snap mode, while un

checking it disables the snap mode; the checked state of a snap type indicates that t

he type is enabled, and unchecked indicates it is disabled. 
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 Figure: Snap Settings Dialog Box 

③ Click "Select All" to check all snap types; click "Clear All" to uncheck all s

nap types. 

④ Click the "OK" button to make the settings take effect; click the "Cancel" bu

tton to discard the settings. 

2.2 File Module 

The File module includes creating a new project, opening a project, saving a project, 

and settings. 
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Figure: File Menu 

 

2.2.1 New Project 

Function Description: 

Create a new project to manage point cloud, vector, DEM, image, or model data. 

Operation Steps: 

① Click File -> New Project. A default project named "工程.hcprj" (Project.hcprj) is

 created. 

2.2.2 Open Project 

Function Description: 

Open a saved project, which will automatically load point cloud, vector, DEM, image, 

or model data under the project. 

Operation Steps: 

① Click File -> Open Project, select the .hcprj file, and click Open. 

2.2.3 Save Project 

Function Description: 

Save the project for loading of point cloud, vector, DEM, image, or OSGB model dat

a by reopening the project later. 

Operation Steps: 
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① After importing point cloud, vector, DEM, image, or OSGB model data, click Fil

e -> Save Project, select the save path, enter a file name, and click Save. 

2.2.4 Settings 

2.2.4.1 Shortcut Keys 

Function Description: 

Provide keyboard command combinations for high-frequency operations to quickly exec

ute commands, switch interfaces, or trigger tools, reducing reliance on the mouse and 

improving operation efficiency. Support user-defined key positions, ensuring consistent 

operation logic and visualized shortcut prompts. 

Operation Steps: 

① Click File -> Settings -> Shortcut Keys to open the shortcut key settings interfac

e. 

 

 

Figure: Settings Location 
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 Figure: Shortcut Keys 

② In the function list, select the function for which you want to add or modify a s

hortcut key. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

102 

 

Figure: Select Function 

③ Select the shortcut key input box, enter the shortcut key, click the "Confirm" butt

on below the input box. The entered shortcut key will be bound to the currently 

selected function. Click "OK" in the bottom right corner of the interface to make 

the binding effective. 

④ After selecting a function, all shortcut keys corresponding to the selected function

 will appear in the current shortcut key list. Click the red “Delete” button on the

 right of a shortcut key to unbind it from the selected function. Click "Ok" in th

e bottom right corner to make the unbinding effective. 
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Figure: Delete Shortcut Key 

⑤ Click the "Reset All" button in the bottom left corner of the shortcut key interfac

e to reset all shortcut keys in the software. Click the "OK" button in the bottom 

right corner to make the reset effective. 
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Figure: Reset All 

⑥ The software occupies some default shortcut keys, which cannot be bound to spe

cific functions. The default occupied shortcut keys are as follows: 

 

Table: Default Occupied Shortcut Keys 

Shortcut keys Function 

Esc Cancel 

Ctrl+Z Undo 

Ctrl+Y Redo 
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Delete Delete 

 

2.2.4.2 Language 

Function Description: 

Support multilingual interface switching and content adaptation to meet user localizatio

n needs (e.g., Chinese/English), ensuring barrier-free cross-regional collaboration and en

hancing the international user experience. 

Operation Steps: 

 

① Click File -> Settings -> Language to open the language settings interface. 

 

 

Figure: language 
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② Select a language from the drop-down box in the language options, click "OK" i

n the bottom right corner. In the pop-up restart prompt box, click "OK". The lan

guage modification will take effect after restarting (if the current project is not sa

ved, you need to save or discard the project after clicking "Confirm Restart"). 

 

 

Figure: Restart After Language Modification 

2.2.4.3 Advanced Settings 

Function Description: 

The purpose of the User Experience Experience Improvement Program is to analyze abnormal 

information during product usage to enhance product stability, and to analyze product usage to 

improve product usability, thereby providing users with more stable products and better user 

experience. To this end, the software will check "User Experience Improvement Program" by 

default, and will collect software operation information (start-up time, shutdown time, crash 

time, operation records such as: create new project, open project, save project, open vector, 

open point cloud, open DEM, open image, open OSGB model, open OSGB folder, create new 

drawing, open drawing, save drawing, save drawing as) and network information. 

If "User Experience Improvement Program" is not checked, no information will be collected. 

Operation Steps: 

1.Click File -> Settings -> Advanced Settings, check the option of user experience im

provement program. 
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Figure: Advanced Settings 

2. The "User Experience Improvement Program" is checked by default, and the software 

will collect operation information. 

3. After changing the check status of the "User Experience Improvement Program", 

click "Cancel" or exit the window from the upper right corner, and a "Close" dialog box will 

pop up. Click "No" or exit the window in the upper right corner of the "Close" dialog box to 

directly close it and return to the "Settings" dialog box interface, where the "User Experience 

Improvement Program" will display the changed status. 
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Figure: Close Dialog 

4. After changing the check status of the "User Experience Improvement Program", 

click the "Ok" button to directly close both the "Close" dialog box and the "Settings" dialog 

box. When the function is opened again, the "User Experience Improvement Program" will 

display the changed status. 

2.3 Base Module 

2.3.1 Data Exchange 

2.3.1.1 Import Point Cloud 
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Function Description: 

Open point cloud data and display it in the view. Supported point cloud data formats 

include *.hpc, *.las, *.laz, and *.codata. 

Operation Steps: 

① Click Base -> Import Point Cloud to pop up the "Select Point Cloud Data File" 

path selection dialog box. 

 

Figure: Import Point Cloud 

 

Figure: Select Point Cloud Data File Dialog Box 
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② In the path selection dialog box, select point cloud data in .hpc/.las/.laz/.codata fo

rmat, click "Open". After the progress bar finishes, the point cloud data will be l

oaded into the view. 

 

Notes: 

1. The *.hpc format is a custom data type of the software, supporting loading of lar

ge datasets with higher efficiency in browsing or processing data. When loading p

oint cloud data in other formats (e.g., *.las, *.laz, *.codata), the data will first be 

converted to *.hpc format before being loaded into the view. 

2. Supports las format of version 1.4 and below. 

 

2.3.1.2 Coordinate File 

Function Description: 

Load coordinate data in .dat, .csv, or .txt format into the currently drawing and displa

y it in the view. 

Operation Steps: 

① Click Base -> Import/Export -> Coordinate File to pop up the path selection dial

og box for importing coordinate files. 

 

Figure: Coordinate File Button 

② Select a coordinate file in .txt, .dat, or .csv format, click "Open". The "Import C

oordinate File" dialog box will appear in the software interface. 
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Figure: Open Coordinate File 

③ In the "Import Coordinate Point" dialog box, select corresponding X, Y, Z axis. 

Click "OK" to import the coordinate file into the currently drawing and display it

 in the view. 

 

Figure: Import Coordinate File Dialog Box 
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Figure: Coordinate File Display Effect 

2.3.2 View 

This section introduces view management functions, including creating a new view wi

ndow, adjusting view window layout, and resetting the layout. 

 

Figure: View Management Buttons 

2.3.2.1 New View 

Function Description: 

Create and open a new view. 

 

 

Operation Steps: 

① Click Base -> Click “New” to create a new view. 
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② Drag point cloud, vector, DEM, image, or model data from the project manageme

nt panel to the new view to load the data. 

 

Note: A maximum of four views can exist simultaneously. 

2.3.2.2 Layout 

Function Description: 

Window layout applies when multiple views exist, providing four modes: Tab Layout, 

Tile Layout, Horizontal Layout, and Vertical Layout. 

 

 

Figure: Layout Button Options 

Operation Steps: 

① Click Base -> New View to create at least two view windows. 

② Click Base -> Layout, and select Horizontal Layout, Vertical Layout, Tile Layout,

 or Tab Layout to view different layouts. 

 

Note: 

The layout function is effective for multiple views. When multiple views exist, the cu

rrently active view is marked with an orange horizontal line in the view title. 
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 Figure: Current Active View Mark 

2.3.2.3 Reset 

Function Description: 

Restore multiple views to the default layout (Tab Layout). 

Operation Steps: 

① Click Base -> Reset. 

② The multiple views in the software interface will return to the initial state (Tab L

ayout). 

2.3.3 Clipping 

2.3.3.1 Rectangle Selection 

Function Description: 

Select point clouds by drawing a rectangular frame. 

 

 

 

Operation Steps: 

① Load the point cloud, click Base -> Clipping -> Select -> Rectangle to activate t

he rectangle selection command. 
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②In the view window, left-click to select the top-left corner of the rectangle, hold an

d drag the mouse until the bottom-right corner is reached. Release the mouse, an

d the point clouds in the rectangular area will be highlighted. 

③After the first selection, you can continue to draw rectangles. The selection area wil

l be added to or subtracted from the existing selection based on the subtract mod

e. 

 

Figure: Rectangle Selection of Point Cloud 

2.3.3.2 Polygon Selection 

Function Description: 

Select point clouds by drawing a polygon. 

 

Operation Steps: 

 

① Load the point cloud, click Base -> Clipping -> Select -> Polygon to activate th

e polygon selection command. 

② Left-click sequentially to select polygon vertices. Double-click the last vertex to e

nd the polygon selection; the selected area will be highlighted (red) as shown bel

ow. 
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③ If a vertex is incorrectly selected, press Ctrl+Z to cancel the last selected point 

(supports multiple consecutive cancellations). 

④ After the first selection, you can make multiple selections based on the initial sel

ection. The selection area will be added to or subtracted from the existing selecti

on based on the subtract mode. 

 

Figure: Polygon Selection of Point Cloud 

2.3.3.3 Lasso Selection 

Function Description: 

Select point clouds by drawing a lasso. 

Operation Steps: 

① Load the point cloud, click Base -> Clipping -> Select -> Lasso to activate the l

asso selection command. 

② Left-click once, then move the mouse. All point clouds within the closed area for

med during mouse movement will be selected. Left-click again to complete a sin

gle lasso selection; the selected area will be highlighted (red) as shown below. 
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③ After the first selection, you can make multiple selections based on the initial sel

ection. The selection area will be added to or subtracted from the existing selecti

on based on the subtract mode. 

 

Figure: Lasso Selection of Point Cloud 

2.3.3.4 Vector Selection 

Function Description: 

Select point clouds by selecting a range line. 

Operation Steps: 

① Load the point cloud and range line, click Base -> Clipping -> Select -> Vector 

selection to activate the range line selection command. 

② Select the range line in the view (supports point selection and frame selection). T

he point clouds within the selected range line will be selected; the selected area 

will be highlighted (red) as shown below. 

③ After the first selection, you can make multiple selections based on the initial sel

ection. The selection area will be added to or subtracted from the existing selecti

on based on the subtract mode. 
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Figure: Range Line Selection of Point Cloud 

2.3.3.5 Inner Clipping 

Function Description: 

Clip off point clouds outside the selection range. 

Operation Steps: 

① Activate the selection function to obtain the selection area; execute the inner clippi

ng function. The clipping effect is shown in the figure. 

② After one clipping, you can continue to select and clip the clipped result multiple 

times. 
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Figure: Inner Clipping Result 

Note: 

Undo: Cancels the last clipping and the coloring result of the selected point cloud. 

Redo: Reverts the last undo operation. 

2.3.3.6 Outer Clipping 

Function Description: 

Clip off point clouds inside the selection range. 

Operation Steps: 

① Activate the selection function to obtain the selection area; execute the outer clippi

ng function. 

② After one clipping, you can continue to select and clip the clipped result multiple 

times. 

 

1.  
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Figure: Outer Clipping Result 

Note: 

Undo: Cancels the last clipping and the coloring result of the selected point cloud. 

Redo: Reverts the last undo operation. 

2.3.3.7 Deselect 

Function Description: 

This function works with Rectangle Selection, Polygon Selection, Lasso Selection, and 

Vector Selection to control whether the current selection is added to or subtracted fro

m the existing selection. The deselection mode is only selectable when a selection co

mmand (Rectangle Selection, Polygon Selection, Lasso Selection, Range Line Selectio

n) is active. 

 

 

Operation Steps: 
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① By default, the deselect button is inactive, and selections are in add mode. Each s

election will expand the selected area. 

② When the deselection function is activated, it enters the deselection state, and the 

final result of the selection is that the overlapping part of the currently selected ar

ea is subtracted from the already selected area. 

 

Figure: Deselect 

2.3.3.8 Clear 

Function Description: 

Cancel and clear all selection operations and clipping results. 

Operation Steps: 

① Execute selection or clipping operations; the selected area or clipping result will b

e highlighted. 

② Execute the clear clipping command to immediately delete all selections and clippi

ng results. 

 

Note: 

Undo: Cancels the last clipping and the coloring result of the selected point cloud. 

Redo: Reverts the last undo operation. 

2.3.4 Slicing 

2.3.4.1 Horizontal 
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Function Description: 

Create a new horizontal slice by selecting a point. 

Operation Steps: 

① Click Base -> Slicing -> Horizontal. The slice settings panel will appear on the ri

ght side of the software. 

 

Figure: Activate Horizontal Slice 

② Left-click to select a point on the point cloud to create a new horizontal slice. H

old Ctrl and scroll the mouse wheel to move the slice; hold Shift and scroll the 

mouse wheel to adjust the display thickness of the horizontal slice. 
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Figure: Horizontal Slice 

③ In the slice settings panel, modify the maximum and minimum values of the eleva

tion range and the slice thickness to accurately update the horizontal slice result. 

 

Figure: Modifying Elevation Range for Horizontal Slice 

④ Modify the movement step, click "Forward" or "Backward" to directly update the 

horizontal slice result; the maximum and minimum values of the elevation range 

will also be updated in real time. 
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Figure: Modify Movement Step for Horizontal Slice 

⑤ Click "Switch" to display the point cloud before horizontal slicing; click "Switch" 

again to display the point cloud after horizontal slicing. 

 

Note: 
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For horizontal slicing, the "Reset" button in the slice settings is grayed out. 

2.3.4.2 Vertical 

Function Description: 

Create a vertical slice. 

Operation Steps: 

① Click Base -> Slicing -> Vertical to enter the vertical slicing command. The view 

will automatically switch to top view, and the slice settings panel will appear on t

he right. 

 

 

Figure: Activate Vertical Slice 

② Left-click sequentially to select two points and create a vertical slice. Hold Ctrl a

nd scroll the mouse wheel to move the slice; hold Shift and scroll the mouse wh

eel to adjust the display thickness of the slice. 
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Figure: Vertical Slice 

③ In the slice settings panel, modify the slice thickness to directly update the vertica

l slice result. 

 

 

Figure: Modify Vertical Slice Thickness 

④ Modify the movement step, click "Forward" or "Backward" to directly update the 

vertical slice result. 
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Figure: Modify Movement Step for Vertical Slice 

⑤ Click "Reset" in the slice settings to restore the view of the point cloud after vert

ical slicing to the view after the first slicing. 

 

Figure: Vertical Slice Reset Effect 

⑥ Click "Switch" to display the point cloud before vertical slicing; click "Switch" ag

ain to display the point cloud after vertical slicing. 
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Figure: Vertical slice reset effect 

Note: 

For vertical slice thickness, the maximum and minimum values of the elevation range 

are grayed out and cannot be modified. 

 

 

Figure: Grayed-Out Elevation Range for Vertical Slice 

2.3.4.3 Bounding Box 
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Function Description: 

Create a bounding box slice. 

Operation Steps: 

① Click Base -> Slicing -> Bounding Box to enter the bounding box slicing comma

nd. The view will display the bounding box frame, corner points, center point, an

d plane grips, and the bounding box slice settings panel will appear on the right. 

 

 

Figure: Bounding Box Slice 

② Use the mouse to select a corner point. Drag the corner point outside the boundi

ng box: the bounding box expands, and the point cloud remains unchanged. Drag 

the corner point inside the bounding box: the bounding box shrinks, and the poin

t cloud is clipped to the size of the bounding box. During dragging, only the bo

unding box and point cloud are displayed in the view; all corner points, plane gr

ips, and the center point are hidden. 
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Figure: Effect of Moving Corner Points 

③ Place the mouse on the plane grip of the bounding box face. Drag the grip outsi

de the bounding box: push the slice outward, the point cloud remains unchanged, 

and this face of the bounding box moves outward. Drag the grip inside the boun

ding box: push the slice inward, the point cloud is clipped smaller, and this face 

of the bounding box moves inward. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

131 

 

Figure: Effect of Moving Plane Grips 

④ Move the mouse close to the center point of the bounding box, left-click the butt

on to freely move the bounding box. The position and size of the point cloud re

main unchanged; the bounding box is used to clip the point cloud, with only the 

point cloud inside the bounding box retained and the point cloud outside not disp

layed. 
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Figure: Effect of Moving Center Point 

Note: The X-axis is red, the Y-axis is green, and the Z-axis is blue. 

2.3.4.4 Bounding Box Settings 

Function Description: 

Directly modify the bounding box by adjusting parameters in the bounding box setting

s panel. 

Operation Steps: 

① Click Base -> Slicing -> Setting to select the bounding box setting. The settings 

panel will appear on the right. 
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Figure: Bounding Box Settings Pane 
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② Click "Front View", "Left View", "Top View", "Back View", "Right View", or "Bo

ttom View" to switch the display angle of the bounding box. 

 

Figure: Top View Effect 

③ Place the mouse on the X-axis angle adjustment area. Scroll forward: the angle in

creases; scroll backward: the angle decreases. The bounding box in the view rotate

s around the X-axis, with the angle adjustment range of -360° to 360°. Click the 

up/down icons on the right: the up icon increases the angle, and the down icon d

ecreases the angle, with the bounding box rotating around the X-axis. Enter an an

gle value directly in the input box on the right of the X-axis: the bounding box r

otates around the X-axis accordingly. The same applies to the Y and Z axes. 
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Figure: Effect of Modifying XYZ Rotation Angles 

④ Click the "Reset Rotation" button to restore the default XYZ axes. 

⑤ When the bounding box is adjusted in the view, the XYZ (length, width, height) 

dimensions in the bounding box settings panel are updated in real time. Modify th

e XYZ (length, width, height) values of the bounding box dimensions: the length, 

width, and height of the bounding box in the view are updated accordingly. The u

pdated bounding box is used to clip the point cloud in real time, with only the p

oint cloud inside the bounding box retained and the point cloud outside not displa

yed. Modify the XYZ values directly in the input boxes or by scrolling the mous

e. 
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Figure: Effect of Modifying XYZ Dimensions 

⑥ When the center point of the bounding box is dragged in the view, the XYZ coor

dinates of the center point in the bounding box settings panel are updated in real 

time. Modify the XYZ coordinate values of the center point: the bounding box in 

the view is translated according to the center point coordinates. The position and 

size of the point cloud remain unchanged; the bounding box is used to clip the p

oint cloud, with only the point cloud inside the bounding box retained and the po

int cloud outside not displayed. Modify the XYZ values by entering them directly 

or scrolling the mouse over the center point area. 
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Figure: Effect of Modifying XYZ Coordinates of Center Point 

⑦ Check "Edge" to display the bounding box frame in the view; uncheck it to hide 

the frame. The same applies to "Vertex" and "Centroid". 

 

Figure: Effect of Hiding Frame, Vertex, Centroid 

Note: The X-axis is red, the Y-axis is green, and the Z-axis is blue. 

 

2.3.4.5 Switch 

Function Description: 

Switches between normal view and slice view. Highlighting indicates that the slice vie

w is displayed. 

 

Figure: Switch Function Button 
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Operation Steps: 

① Load point cloud and vector data for slicing. The button will be highlighted after 

slicing is completed. 

② Click Base -> Slicing -> Switch to cancel the button highlight and switch to nor

mal view. 

③ Click Base -> Slicing -> Switch again to highlight the button and switch back to 

slice view. 

2.3.4.6 Vector Switch 

Function Description: 

Controls whether vector data is clipped during slicing. By default, the button is not hi

ghlighted, indicating that vector data is not clipped. 

 

 

Operation Steps: 

① Load point cloud and vector data. 

② Click Base -> Slicing -> Vector Switch to highlight the button. 

③ Click Base -> Slicing -> Horizontal to enter horizontal slicing. Left-click to select 

a point on the point cloud to create a new horizontal slice. At this time, vector d

ata will also be clipped. 
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Figure: Horizontal Slice Without Clipping Vectors 

④ Click Base -> Slicing -> Vector Switch to unhighlight the button. 

⑤ Click Base -> Slicing -> Horizontal to enter horizontal slicing. Left-click to select 

a point on the point cloud to create a new horizontal slice. At this time, vector d

ata will not be clipped. The same applies to vertical slicing and bounding box sli

cing. 
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Figure: Horizontal Slice With Clipping Vectors 

2.3.5 Save 

Function Description: 

Saves and exports the results of point cloud clipping or slicing. 

Operation Steps: 

① Load the point cloud, click to activate the "Rectangle/Polygon/Lasso/Vector selectio

n" drawing function, and draw a clipping area in the view. 

② Select "Inner Clipping/Outer Clipping" to obtain the clipping result. 

③ Click Horizontal/Vertical/Bounding Box to slice based on the clipping result and o

btain the slicing result. 

④ Click Base -> Save -> Clip/Slice to pop up the save interface. Select the point cl

oud file to be clipped and saved, set the parameters, and click OK. 
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Figure: Save Clipped Slice 

⑤ In the pop-up dialog box, select the file save directory and enter a file name to s

ave there. If there is only one point cloud file, a folder selection dialog box will 

pop up. After selecting the folder, the clipped point cloud will be directly saved t

o the selected folder path. File naming rule: Time_OriginalPointCloudName. 

Parameter Settings 

Sampling Settings: Three sampling methods are available: "Random Sampling, Grid S

ampling, No Sampling". 

 

Sampling Rate (%): Default is 10%, with a range of 0.01-99.99%. Sampling is perfo

rmed according to the set sampling rate; the smaller the sampling rate, the fewer poin

ts are retained. 
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Grid Side Length (m): Sampling is performed according to the grid side length. At 

most one point is retained in each grid. The default side length is 0.1m. A smaller gr

id side length results in slower thinning and more retained points; a larger grid side l

ength results in faster thinning and fewer retained points. 

 

Save Format: Supports exporting clipped point clouds in las or hpc format. 

Load into Current View: If checked, the saved point cloud will be automatically load

ed into the current view. 

 

Unload Original Point Cloud: If checked, the selected point cloud file will be autom

atically unloaded after successful saving. 

 

Merge File: If more than one point cloud is involved in clipping, check this option t

o merge the clipped point clouds into a single file. 

2.3.6 Check 

2.3.6.1 Precision 

Function Description: 

Supports automatic elevation matching and manual point-picking planar matching for p

oint clouds, automatically calculates indicators such as planar/elevation root mean squa

re error (RMSE) and maximum deviation of point clouds, generates statistical reports, 

and accurately locates error distributions. 

 

 

 

 

 

 

Operation Steps: 

① Click Base-> Check -> precision to open the precision check interface. 
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Figure: Precision 

 

Figure: Precision Check Interface 

 

② Click "Import", select a coordinate file (supports .dat, .txt, .csv formats). After ope

ning, adjust the corresponding columns with the import coordinate file, then click 

OK to import the coordinate data. 
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Figure: Precision Coordinate Import 

③ Click the "Add" button to add a blank row to the list. Double-click to manually e

nter known points. 
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Figure: Manually Enter Known Points 

④ After successful data import or manual entry of known points, positioning labels f

or existing points will appear in the view. Meanwhile, in the coordinate data list, 

you can modify the point name, type, X, Y, Z, Match_X, Match_Y, and Match_Z 

values by double-clicking to select. 
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Figure: Label 

⑤ Coordinate points are divided into three types: Z points, XY points, and 3D point

s. 

 Z points: Only perform elevation precision check. 

 XY points: Only perform planar precision check. 

 3D points: Perform both elevation and planar precision check. 

 

Figure: Point Types 
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⑥ The "Planar RMSE Limit" and "Elevation RMSE Limit" input boxes below the co

ordinate list can be used to set error limits. 

⑦ In the automatic matching section of the precision check, check the elevation poin

t option, set the neighborhood radius, and click the "Match" button to perform ele

vation matching for all elevation points. After matching, the automatic matching se

ction of the precision check displays the number of successfully matched points. T

he DeltaZ value of points within the elevation limit has no background color; the 

DeltaZ value of points outside the elevation limit but within twice the elevation li

mit has an orange background; the DeltaZ value of points outside twice the elevat

ion limit has a red background. 

 

 

Figure: Within Limit 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

148 

 

Figure: Outside Limit, Within Twice the Limit 
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Figure: Outside Twice the Limit 

⑧ In the RMSE section, you can modify the RMSE calculation method and choose 

whether to eliminate gross errors. There are three error calculation methods: same-

precision, high-precision, and mean-precision check. 
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Figure: RMSE 

⑨ After precision checking, you can export and preview the report. Click the "Previe

w" button to pop up the precision check report; click "Export Report" to export a 

report with PDF format. 

2.3.6.2 Measure 

This section introduces measurement functions, including point measurement, length me

asurement, area measurement, angle measurement, and density measurement. 
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Figure: Measure Buttons 

2.3.6.2.1 Point 

Function Description: 

Left-click to select a point on the point cloud in the view window to query informati

on such as coordinates, intensity, time, and classification of the point. If no point clou

d is captured, only the coordinates of the blank point are displayed. 

Operation Steps: 

① Click Base -> Measure -> Point to enter point measurement mode. 

② Left-click a point on the point cloud in the view window. An information box wil

l display XYZ coordinates, intensity, time, classification, RGB color, etc., which w

ill also be displayed in the output window. 
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Figure: Point Measurement  

③ Left-click a blank area in the view window or loaded vector, DEM, image, or mo

del data. If no point cloud is captured, only the coordinates of the blank point are

 displayed. 
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Figure: Point Measurement  

 

Note: 

When the point cloud is sparse, it may be difficult to select a point. In this case, yo

u can zoom in on the point cloud before selecting a point for query. 

2.3.6.2.2 Length 

Function Description: 

The length measurement tool uses mouse clicks to query the 2D and 3D distances bet

ween two points. 

Operation Steps: 

① Click Base -> Measure -> Length to enter length measurement mode. 

② Left-click sequentially to select multiple points in the view window. The informati

on box displays the 2D length, 3D length of the polyline between points, and the 

distance differences in XYZ directions between the current point and the previous 

point. 
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Figure: Length Measurement 

2.3.6.2.3 Area 

Function Description: 

The area measurement function calculates the projected area by drawing a polygon. 

Operation Steps: 

① Click Base -> Measure -> Area to enter area measurement mode. 

② Left-click to select the corner points of the polygon. The enclosed area will be di

splayed in real time. 
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Figure: Area Measurement 

Note: 

Area measurement requires selecting at least three points to calculate the area 

2.3.6.2.4 Angle 

Function Description: 

The angle measurement function calculates the angle of the polyline by selecting three

 points to draw a polyline. 

Operation Steps: 

① Click Base -> Measure -> Angle to enter angle measurement mode. 

② Left-click to select three points to draw a polyline. The angle of the polyline is d

isplayed. 
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Figure: Angle Measurement 

Note: 

Angle measurement requires selecting at least three points to calculate the angle of th

e intersection in the selected region. 

2.3.6.2.5 Density 

Function Description: 

Obtains point density by calculating the average number of points per square meter. P

oint density can be used as an important indicator to evaluate the quality of point clo

ud data. 

Operation Steps: 

① Click Base -> Measure -> Density to enter the point density measurement comma

nd. 

② By default, it calculates and displays the point density per square meter. You can 

also enter the length of the square manually, then left-click a point to calculate th

e point density within the selected range. 

③ Click the close button in the upper right corner of the point density to end and e

xit the point density measurement command. 
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Figure: Density Measurement 

2.3.7 Window 

This section mainly introduces window display. Users can freely choose which windo

ws to show or hide. 

 

 

Figure: Window Display 

 

 

2.3.7.1 Output Window 
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Function Description: 

Displays key operation steps and processing results during operations. Click Base -> 

Windows to show or hide the output window. 

 

Figure: Output Window 

Operation Steps: 

① The output window is highlighted and loaded by default. 

② Click Base -> Windows to unhighlight the output window and hide it. Click again

 to highlight the output window button and display the window. 

2.3.7.1.1 Single Selection/Multiple Selection 

Function Description: 

Allows selecting information in the output window to highlight it. 

 

Figure: Selecting Information in Output Window 

Operation Steps: 

 

① Left-click once in the output window to select a row of information, which will b

e highlighted. 

② Left-click once in the output window to select a row of information, then hold th

e left mouse button and drag up or down to select multiple rows of information i

n the output window, which will be highlighted. 

③ Left-click once in the output window to select a row of information, then press th

e Shift key and select the last row of information to select multiple rows of infor
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mation in the output window, which will be highlighted. 

2.3.7.1.2 Copy 

Function Description: 

Copies selected information in the output window to the clipboard. 

 

Figure: Copying Information in Output Window 

Operation Steps: 

After selecting information in the output window, right-click and select "Copy" or use 

the shortcut key Ctrl+C. 

2.3.7.1.3 Select All 

Function Description: 

Selects all information in the output window, which will be fully highlighted. 

 

 

Figure: Selecting All Information in Output Window 

Operation Steps: 

Right-click in the output window to bring up the menu, select "Select All" or use the

 shortcut key Ctrl+A. The selected information will be highlighted. 
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2.3.7.1.4 Clear 

Function Description: 

Clears all information in the output window. 

 

 

Figure: Clearing Information in Output Window 

Operation Steps: 

Right-click in the output window to bring up the menu, select "Clear" to clear all inf

ormation in the output window. 

 

 

 

 

2.3.7.2 Project Management 

Function Description: 

Click Base -> Project to show or hide the project management panel. 
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Figure: Project Management 

Operation Steps: 

① The project management panel is highlighted and loaded by default. 

② Click Base-> Project to unhighlight the panel and hide it. Click again to highlight 

the project management button and display the panel. 

2.3.7.2.1 Data Management Panel 

Function Description: 

The data management panel can manage vector, point cloud, DEM, image, OSGB, and

 other data. 
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Figure: Data Management Panel 

2.3.7.2.1.1 Open Vector 

Function Description: 

Loads vectors in dxf or dwg format. 

Operation Steps: 

① Project node -> Right-click Vector node, bring up the menu, and left-click "Open 

Vector" as shown in the figure. 

 

Figure: Right-Click to Open Vector in Folder 

② A vector data selection dialog box will pop up. Select the path of the vector data 

in dxf or dwg format, click "Open" to load the vector data into the view. Meanw

hile, the vector data is mounted under the vector folder node, and it is in an inac
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tive state by default (the icon on the left of the vector data is not highlighted). 

 

Figure: Vector Selection Dialog Box 

 

2.3.7.2.1.2 Open Point Cloud 

Function Description: 

Loads point clouds in las, codata, laz, or hpc format. 

Operation Steps: 

① Project node -> Right-click point cloud node, select and left-click "Open Point Clo

ud" in the menu as shown in the figure. 
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Figure: Project Management to Open Point Cloud 

 

② Select point cloud data in las, codata, laz, or hpc format to load the point cloud i

nto the view. The imported data is mounted under the point cloud node. 

 

Figure: Loading Point Cloud Data 

 

 

 

2.3.7.2.1.3 Open DEM 
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Function Description: 

Loads DEM data in tif or tiff format via project management. 

Operation Steps: 

① Project node -> Right-click Grid node, select and left-click "Open DEM" in the m

enu as shown in the figure. 

 

Figure: Open DEM 

② Select DEM data in tif or tiff format to load the DEM into the view. The import

ed data is mounted under the grid node. 

 

 

2.3.7.2.1.4 Open Image 

Function Description: 

Loads image data in formats such as tif or jpg via project management. 

 

 

 

 

 

Operation Steps: 

① Project node -> Right-click grid node, select and left-click "Open Raster" in the 

menu as shown in the figure. 
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Figure: Open Image 

② Select image data in tif or jpg format to load the image into the view. The impor

ted data is mounted under the grid node. 

2.3.7.2.1.5 Open OSGB Model 

Function Description: 

Loads model data in osgb format via project management. 

Operation Steps: 

① Project node -> Right-click Model node, select and left-click "Open OSGB" in the

 menu as shown in the figure. 

 

 

Figure: Open OSGB Model 
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② Select data in osgb format to load the OSGB model data into the view. 

 

 

2.3.7.2.1.6 Open OSGB Folder 

Function Description: 

Loads OSGB model folder data in osgb format via project management. 

 

 

 

 

Operation Steps: 

① Project node -> Right-click Model node, select and left-click "Open OSGB Dir" in

 the menu as shown in the figure. 

 

 

Figure: Open OSGB Folder 

② Select data in osgb format to load the OSGB model data into the view. 

 

2.3.7.2.1.7 Create New Folder 

Function Description: 

Creates a new folder in project management. 

Operation Steps: 

① If you right-click an existing folder (Point Cloud/Vector/Grid/Model/Terrain/Other) and 
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select "Create Directory", the new folder will be created under the existing folder. 

 

Figure: Create New Folder 

 

② If you right-click a blank area in the data panel and select "Create Directory", the ne

w folder will be created under the root node of the project, at the same level as exis

ting folders. 

 

Figure: Create New First-Class Directory 
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2.3.7.2.1.8 Rename 

Function Description: 

Renames a folder. 

Operation Steps: 

Double-click the folder to be renamed. The current full name of the folder is selected

 by default. Enter the new name of the folder in the input box, then left-click or pre

ss Enter to confirm the modification. 

 

 

Figure: Rename 

2.3.7.2.1.9 Delete Folder 

Function Description: 

Deletes a folder and the data in it from the project management node and the view. 

 

 

 

 

Operation Steps: 

Project node -> Folder (Point Cloud/Vector/Raster/Model/Panorama/Other), right-click a

ny one and click "Delete Directory" to delete the folder. If the folder contains data, s
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elect "Ok" in the pop-up prompt box to delete the folder and its data, and remove th

e data from the view window. 

 

 

Figure: Delete Folder 

2.3.7.2.1.10 Import Control Point 

Function Description: 

Loads Control Points in dat, csv, or txt format into the currently active drawing and 

displays it in the view. 

Operation Steps: 

① Project node -> Folder (right-click) -> Import Control Point, select a coordinate fil

e in txt, dat, or csv format, click "Open". A coordinate file dialog box will appea

r in the software interface. 
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Figure: Open Coordinate File 

 

Figure: Import Coordinate File Dialog Box 

② In the "Import Control Point" dialog box, make settings to ensure both X and Y 

columns exist and contain coordinate data. Click "OK" to import the coordinate fil

e into the currently active drawing and display it in the view. 

2.  
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Figure: Coordinate File Display Effect 

2.3.7.2.1.11 Right-Click Menu in Blank Area 

Function Description: 

Right-clicking in the blank area of project management allows loading vector, point cl

oud, DEM, image, OSGB, coordinate files, etc., and creating folders. 

Operation Steps: 

① Right-click a blank area in the data panel to pop up a menu. You can load vecto

r, point cloud, DEM, image, OSGB models, or coordinate files, and create new fo

lders in project management. The loaded data or new folders will be mounted at t

he bottom of the project tree. 
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Figure: Right-Click Menu in Blank Area 

 

2.3.7.2.1.12 Drag to Open Data 

Function Description: 

Drag point cloud, vector, DEM image, or OSGB data to the view window or project 

management panel to load it. When dragging las, codata, or laz point clouds, they wil

l be directly converted to hpc format. 

Operation Steps: 

① Select one or more point cloud, vector, DEM image, OSGB model, or OSGB fold

er data, hold the left mouse button, and drag the data into the view/data managem

ent panel. 

② Release the left mouse button to load and display the dragged data in the view w

indow or data management panel. 
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Figure: Dragging Data to View Window 

 

Figure: Dragging Data to project Management Panel 

 

2.3.7.2.1.13 Close 
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Function Description: 

Deletes data from the project management node. 

Operation Steps: 

① Select data in the data panel, right-click to pop up the menu, select "Close" to de

lete the data from the project management node and the view. 

 

Figure: Close Data 

 

2.3.7.2.1.14 Redirect 

Function Description: 

Re-selects the loaded data path without changing the data name in the node. 

 

Operation Steps: 

① Select data in the data panel, right-click to pop up the menu, select "Redirect", an

d re-select the loaded data path in the pop-up selection box. 
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Figure: Redirect 

2.3.7.2.1.15 Open File Directory 

Function Description: 

Opens the storage directory of the data file in the data panel. 

Operation Steps: 

① Select data in the data panel, right-click to pop up the menu, select "Open File D

irectory" to pop up the Windows File Explorer and open the directory where the 

data is located. 

 

 

Figure: Open Folder 

 

2.3.7.2.1.16 Activate Drawing 

Function Description: 

Activate the drawing. 

Operation Steps: 

① Load vector data. 

② Right-click and select "Set Activate" to make the vector data active and editable. 
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Figure: Activate Drawing 

 

 

2.3.7.2.2 View Management Panel 

2.3.7.2.2.1 Close 

Function Description: 

Close the selected view and the data within it, but the data remains in the data panel

 and is not removed, and can be dragged to other views. 

Operation Steps: 

In the view panel, select one or more displayed views, right-click, and select "Close" 

in the pop-up menu to close the selected views. 
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Figure: Close View 

2.3.7.2.2.2 Center 

Function Description: 

Display the selected data centered in the view. 

Operation Steps: 

In the view panel, select one or more displayed data, right-click, and select "Set Cent

er" in the pop-up menu. The selected data will be displayed centered in the view. 

 

Figure: Center Display Data 

2.3.7.2.2.3 Hide 

Function Description: 

Hide the displayed data in the view. 

Operation Steps: 

In the view panel, select one or more displayed data, right-click, and select "Hide" in 

the pop-up menu, or click the small eye icon on the right  indicates the data is i

n the displayed state，  indicates the data is in the hidden state. 

 

Figure: Hide Data 
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2.3.7.2.2.4 Show 

Function Description: 

Display hidden data in the view. 

Operation Steps: 

① In the view panel, select one or more hidden data, right-click, and select "Show" 

in the pop-up menu, or click the small eye icon on the right 

② indicates the data is in the displayed state; indicates the data is in the hid

den state. 

 

 

Figure: Show Data 

 

2.3.7.2.2.5 Remove 

Function Description: 

Remove one or more data from the view. 

Operation Steps: 

In the view panel, select one or more displayed data, right-click, and select "Remove"

 in the pop-up menu. 
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Figure: Remove Data 

Note: Data is only removed from the view and not from the software. 

 

2.3.7.3 Property Panel 

Function Description: 

When a vector is selected, the property panel allows viewing or modifying all public 

attribute information of the selected vector. Click Base -> Property Panel to show or 

hide the property panel. 

2.3.7.3.1 Point 

Function Description: 

When only point elements are selected, the property panel displays the attribute infor

mation of the selected points. 

 

Operation Steps: 

① In the view, select one or more point elements. The information will appear in th

e property panel. 
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Figure: Point Information in Property Panel 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of point elements can be adjusted by selecting from drop-down boxe

s. 

 

Figure: Modify Point Information via Drop-down in Property Panel 
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③ In the property panel, the line type scale and thickness of points can be adjusted 

by inputting values. 

 

Figure: Modify Point Information via Input in Property Panel 

 

2.3.7.3.2 Line 

Function Description: 

When only line features are selected, the property panel displays the attribute informat

ion of the selected lines. 

 

Operation Steps: 

 

① In the view, select one or more line data. The information of the selected lines 

will appear in the property panel. 
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Figure: Line Information in Property Panel 

 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of lines can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the line type scale and thickness of lines can be adjusted 

by inputting values. 

 

2.3.7.3.3 Polyline 
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Function Description: 

When only polyline elements are selected, the property panel displays the attribute inf

ormation of the selected polylines. 

 

Operation Steps: 

① In the view, select one or more polyline data. The information of the selected po

lylines will appear in the property panel. 
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Figure: Selected Polyline 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of polylines can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the line type scale, thickness, vertex number, and elevation 

of polylines can be adjusted by inputting values. 
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④ In the property panel, the on/off status of the closed and line type generation fun

ctions can be modified by checking or unchecking the checkboxes. 

 

Figure: Check Options in Property Panel 
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2.3.7.3.4 3D Polyline 

Function Description: 

When only 3D polyline elements are selected, the property panel displays the attribute

 information of the selected 3D polylines. 

 

Operation Steps: 

① In the view, select one or more 3D polyline data. The information of the selecte

d 3D polylines will appear in the property panel. 

 

 

Figure: Selected 3D Polyline 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of 3D polylines can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the line type scale and thickness of 3D polylines can be a

djusted by inputting values. 

2.3.7.3.5 Circle 
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Function Description: 

When only circle elements are selected, the property panel displays the attribute infor

mation of the selected circles. 

 

Operation Steps: 

① In the view, select one or more circles. The information of the selected circles w

ill appear in the property panel. 

 

 

Figure: Selected Circle 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of circles can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the line type scale and thickness of circles can be adjusted

 by inputting values. 

 2.3.7.3.6 Arc 
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Function Description: 

When only arc elements are selected, the property panel displays the attribute informat

ion of the selected arcs. 

 

Operation Steps: 

① In the view, select one or more arcs. The information of the selected arcs will a

ppear in the property panel. 

 

Figure: Selected Arc 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of arcs can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the line type scale and thickness of arcs can be adjusted b

y inputting values. 

2.3.7.3.7 Spline Curve 
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Function Description: 

When only spline curve elements are selected, the property panel displays the attribute

 information of the selected spline curves. 

 

Operation Steps: 

① In the view, select one or more spline curves. The information of the selected sp

line curves will appear in the property panel. 

 

 

Figure: Selected Spline Curve 

② In the property panel, the color, layer, line type, line type scale, line width, and t

ransparency of spline curves can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the line type scale and thickness of spline curves can be a

djusted by inputting values. 
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 2.3.7.3.8 Pattern Fill 

Function Description: 

When only pattern fill elements are selected, the property panel displays the attribute i

nformation of the selected pattern fills. 

 

Operation Steps: 

① In the view, select one or more pattern fills. The information of the selected patt

ern fills will appear in the property panel. 
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Figure: Selected Pattern Fill 

 

② In the property panel, the color, layer, line type, line type scale, line width, trans

parency, and fill style of pattern fills can be adjusted by selecting from drop-dow

n boxes. 

③ In the property panel, the angle and scale of pattern fills can be adjusted by inp

utting values. 

④ In the property panel, the on/off status of pattern combination, association, and an

notation functions can be modified by checking or unchecking the checkboxes. 

2.3.7.3.9 Text 

Function Description: 

When only text elements are selected, the property panel displays the attribute informa

tion of the selected text. 

 

Operation Steps: 

① In the view, select one or more text elements. The information of the selected te

xt will appear in the property panel. 
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Figure: Selected Text 

② In the property panel, the color, layer, line type, line type scale, line width, trans

parency, and fill style of text can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the thickness and position of text can be adjusted by input

ting values. 

④ In the property panel, the on/off status of annotation, upside down, and reverse f

unctions can be modified by checking or unchecking the checkboxes. 

2.3.7.3.10 Multiline Text 
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Function Description: 

When only multiline text elements are selected, the property panel displays the attribut

e information of the selected multiline text. 

 

Operation Steps: 

① In the view, select one or more multiline text elements. The information of the s

elected multiline text will appear in the property panel. 

 

 

Figure: Selected Multiline Text 

In the property panel, the color, layer, line type, line type scale, line width, and trans

parency of multiline text can be adjusted by selecting from drop-down boxes. 

2.3.7.3.11 Align Dimension 

Function Description: 

When only aligned dimension elements are selected, the property panel displays the at

tribute information of the selected aligned dimensions. 
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Operation Steps: 

 

① In the view, select one or more aligned dimensions. The information of the select

ed aligned dimensions will appear in the property panel. 
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Figure: Selected Aligned Dimension 1 
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Figure: Selected Aligned Dimension 2 

② In the property panel, the color, layer, line type, line type scale, line width, trans

parency, dimension line color, dimension line style, and text color of aligned dim

ensions can be adjusted by selecting from drop-down boxes. 

③ In the property panel, the dimension line text, text/line spacing, measurement, line

 type scale, separator, prefix, suffix, multiple dimensioning, tapered dimensioning, 

dimension precision, dimension scale, dimension，move dimension, shape check, la

bel check, inspection rate, text height, and extension length of aligned dimensions

 can be adjusted by inputting values. 

④ In the property panel, the on/off status of arrow/line spacing, text/arrow spacing, t

ext reverse, and dimension functions can be modified by checking or unchecking 

the checkboxes. 

2.4 Vector Module 

2.4.1 Drawings 

2.4.1.1 New Drawing 

Function Description: 

Create a new drawing in dwg or dxf format. 

 

Operation Steps: 

① Click Vector -> Drawings -> New Drawing to pop up the New Drawing dialog 

box. 

② After selecting the save path for the new drawing, enter the name of the new dr

awing in the "File name" field. Select ".dxf" or ".dwg" from the drop-down optio

ns next to "Save as type" and click "Save" to create a drawing in the correspond

ing format. If no selection is made or the default ".dwg;.dxf" is selected, clicking

 "Save" will create a dwg format drawing by default. 
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Figure: New Drawing 

③ The successfully created drawing is loaded into "Project Management" by default 

and is in an inactive state. 

 

Figure: Project Management 

 

2.4.1.2 Open Drawing 

Function Description: 

Open a drawing in dwg or dxf format. 

 

Operation Steps: 

① Click Vector -> Drawings -> Open Drawing to pop up the Open File dialog box. 
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② Select the drawing to be opened, or directly enter the absolute path of the drawi

ng in the input box after "", and click "Open" to load the drawing. 

 

 

Figure: Open File 

③ The successfully opened drawing is loaded into "Project Management" by default 

and is in an inactive state. 

 

Figure: Project Management 

 

2.4.1.3 Save Drawing 

2.4.1.3.1 Save 
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Function Description: 

Save a drawing in dwg or dxf format. 

 

Operation Steps: 

① If the drawing already has a path, after clicking Vector -> Drawing -> Save, the 

output window will prompt successfully saved in currectly path 

 

Figure: Save Drawing 

② If the drawing has not been saved before, clicking Vector -> Save drawing will p

op up the Save Drawing dialog box. The default file name is "Drawing.dwg". Sel

ect the path, modify the file name if needed, and click "Save" to save successfull

y. 

 

Figure: Save Drawing 
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③ In a saved drawing or a loaded vector file, when a vector element is drawn or e

dited five times, the current drawing will be automatically saved. During saving, 

a progress bar for saving the drawing will appear in the lower right corner of th

e software. After successful saving, the output window will display a prompt mes

sage for saving the drawing. 

z 

Figure: Auto-Save Progress Bar 

 

Figure: Auto-Save Prompt 

2.4.1.3.1 Save As 

Function Description: 

Save a drawing as a copy with a specified file name and format. 

Operation Steps: 

① Click Vector -> Drawings ->" Save as" to pop up the dialog box. 
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Figure: Save As 

 

Figure: Saving path dialog box 
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② Enter the file name and select the save format from the "Save as type" drop-down 

box. The supported formats are DWG and DXF, as shown in the figure below. T

he default format is "2018 DWG (*.dwg)". 

 

Figure: Save as type 

 

③ Click "Save" to complete "Save As" action. 

 

2.4.2 Draw Vector 

2.4.2.1 Point 

Function Description: 

Draw a point in the drawing. 

 

Operation Steps: 

① Click Draw Vector -> Point. 
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Figure: Point 

② In the view, left-click a point to complete the drawing of a point at the clicked 

position. 

2.4.2.2 Polyline 

2.4.2.2.1 Vertex Mode 

Function Description: 

Draw a polyline by determining the endpoints of line segments in the drawing. 

 

Operation Steps: 

① Click Draw Vector -> Polyline -> Vertex Mode. 
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Figure: Vertex Mode 

② In the view, click a point to determine the starting point of the polyline. 

③ In the view, click to specify the next endpoint.  

④ In the view, press Enter to end, or right-click and select "Ok" to complete the p

olyline drawing. The default polyline is not closed. To draw a closed polyline, ri

ght-click "Close" or use the shortcut key C to end the drawing, or right-click an

d check "Auto-Close" to close the polyline. 

⑤ During the polyline drawing process, right-click and select "Undo Point" or use t

he shortcut key U to cancel the previous point. 

⑥ The default is "2D Drawing". During drawing, the vector elevation is always con

strained to the same plane. To draw to the mouse snap position, right-click and s

elect "3D Drawing" to draw to the mouse snap position. 
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Figure: Right-Click Menu in Vertex Mode 

2.4.2.2.2 Right Angle Mode 

Function Description: 

Draw a polyline in the drawing with right-angle line 

 

Operation Steps: 

① Click Draw Vector -> Polyline -> Right Angle Mode. 
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Figure: Right Angle Mode 

② In the view, click two points to determine the starting point. 

③ In the view, click a point to determine the edge perpendicular to the previous ed

ge.  

④ In the view, press Enter to end, or right-click and select "Ok" to complete the p

olyline drawing. The default polyline is not closed. To draw a closed polyline, ri

ght-click "Close" or use the shortcut key C to end the drawing, or right-click an

d check "Auto-Close" to close the polyline. 

⑤ During the polyline drawing process, right-click and select "Undo Point" or use t

he shortcut key U to cancel the previous point. 

⑥ The default is "2D Drawing". In right angle mode, the vector elevation is always 

constrained to the same plane in both "2D Drawing" and "3D Drawing". 
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Figure: Right-Click Menu in Right Angle Mode 

Note: 

① Check "Auto-Close": The first point is closed by drawing a perpendicular line to 

the last edge. 

② Uncheck "Auto-Close": Use the shortcut key C or right-click "Close" to close by 

directly connecting the first and last points. 

2.4.2.2.3 Edge Mode 

Function Description: 

Draw a polyline in the drawing by drawing two points to determine a line segment i

ntersecting the previous edge. 

 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

212 

Operation Steps: 

① Click Draw Vector -> Polyline -> Edge Mode. 

 

Figure: Edge Mode 

② In the view, click two points to determine the first edge of the polyline. And the

n click two points to determine another edge, it will intersect to provious edge. 

③ In the view, press Enter to end, or right-click and select "Ok" to complete the p

olyline drawing. The default polyline is not closed. To draw a closed polyline, ri

ght-click "Close" to end the drawing, or right-click and check "Auto-Close" to cl

ose the polyline. 

④ During the polyline drawing process, right-click and select "Undo Point" or use t

he shortcut key U to cancel the previous point. 

⑤ The default is "2D Drawing". In edge mode, the vector elevation is always constr

ained to the same plane in both "2D Drawing" and "3D Drawing". 
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Figure: Right-Click Menu in Edge Mode 

Note: 

1. Check "Auto-Close": The last edge is closed by intersecting with the first edge. 

If the first edge is exactly parallel to the last edge, the first and last points are 

connected to close. 

2. Uncheck "Auto-Close": Use the shortcut key C or right-click "Close" to close b

y directly connecting the first and last points. 

2.4.2.2.4 Arc Mode 

Function Description: 

Draw a polyline in the drawing by drawing three points to determine an arc. 

 

Operation Steps: 
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① Click Draw Vector -> Polyline -> Arc Mode. 

 

Figure: Arc Mode 

 

② In the view, click a point to determine the start point of the arc. 

③ In the view, click a point to determine the end point of the arc. 

④ In the view, click a point to determine the direction and size of the arc. Continu

e drawing as needed, with the end point of the previous arc as the start point. 

⑤ In the view, press Enter to end, or right-click and select "Ok" to complete the p

olyline drawing. The default polyline is not closed. To draw a closed polyline, ri

ght-click "Close" to end the drawing, or right-click and check "Auto-Close" to cl

ose the polyline. 

⑥ During the polyline drawing process, right-click and select "Undo Point" or use t

he shortcut key U to cancel the previous point. 

⑦ The default is "2D Drawing". The drawn arc is a true arc, and the vector elevati

on is always constrained to the same plane during drawing. To draw to the mous

e snap position, right-click and select "3D Drawing". The start and end points of 

the arc can be drawn to the mouse snap position. In this case, the drawn arc is 

not a true arc but a 3D polyline composed of multiple line segments forming an 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

215 

arc shape. The elevation of the middle arc part is interpolated from the elevations

 of the start and end points of the arc. 

 

 

Figure: Right-Click Menu in Arc Mode 

2.4.2.2.5 Drawing Mode Switch 

The polyline drawing process supports switching between different interaction modes t

o continue drawing. The following details the switching effects between the four mode

s: "Vertex Mode, Right Angle Mode, Edge Mode, Arc Mode". 

 

Vertex to Right Angle: 

If switching to Right Angle Mode after drawing one point in Vertex Mode, the first 

point is used as the first point of the first edge in Right Angle Mode, and drawing c

an continue in Right Angle Mode. If switching to Right Angle Mode after drawing t
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wo or more points in Vertex Mode, a perpendicular line is drawn through the last ver

tex, and this perpendicular line is used as the first edge in Right Angle Mode, and dr

awing can continue in Right Angle Mode. 

 

Check "Auto-Close": The first vertex is closed by drawing a perpendicular line to th

e last edge. 

Uncheck "Auto-Close": All resulting edges are retained. If using the shortcut key C 

or right-click "Close", the first and last points are directly connected to close. 

 

 

Figure: Vertex to Right Angle - Auto-Close Checked 

 

Figure: Vertex to Right Angle - Auto-Close Unchecked 
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Vertex to Edge: 

When switching to Edge Mode during Vertex Mode drawing, the last point is used as

 the first point in Edge Mode, and drawing can continue in Edge Mode. 

 

Check "Auto-Close": When the last edge is determined by two mouse clicks, the firs

t and last points are connected to close; when the last edge is determined by one mo

use click, the first point is closed by intersecting with the extension line of the last p

oint and the tail edge. 

 

Uncheck "Auto-Close": All edges are retained. If using the shortcut key C or right-cl

ick "Close", the first and last points are directly connected to close. 

 

Figure: Vertex to Edge - Auto-Close Checked 
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Figure: Vertex to Edge - Auto-Close Unchecked 

Vertex to Arc: 

When switching to Arc Mode during Vertex Mode drawing, the last point is used as 

the arc start point, and drawing can continue in Arc Mode. 

 

Check "Auto-Close": The first vertex is connected to the last arc end point to close. 

Uncheck "Auto-Close": All edges and confirmed arcs are retained. If using the shortc

ut key C or right-click "Close", the first and last points are directly connected to clos

e 
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Figure: Vertex to Arc - Auto-Close Checked 

 

Figure: Vertex to Arc - Auto-Close Unchecked 

Right Angle to Vertex: 

If switching to Vertex Mode after drawing one point in Right Angle Mode, the drawn

 vectors are cleared. If switching to Vertex Mode after drawing two or more points i

n Right Angle Mode, all edges are retained, the first drawn point is projected onto th

e last edge, and drawing can continue in Vertex Mode. 

 

Check "Auto-Close": The first and last points are connected to close. 

 

Uncheck "Auto-Close": All edges are retained. If using the shortcut key C or right-cl

ick "Close", the first and last points are directly connected to close. 
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Figure: Right Angle to Vertex - Auto-Close Checked 

 

Figure: Right Angle to Vertex - Auto-Close Unchecked 

Right Angle to Edge: 

If switching to Edge Mode after drawing one point in Right Angle Mode, the first po

int is retained as the first point in Edge Mode for continued drawing. If switching to 

Edge Mode after drawing two or more points in Right Angle Mode, all edges determi

ned by two points are retained, and drawing can continue in Edge Mode. 
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Check "Auto-Close": The last edge is closed by intersecting with the first and last e

dges. If the first edge is exactly parallel to the last edge, the first and last points are 

connected to close. 

 

Uncheck "Auto-Close": All edges are retained. If using the shortcut key C or right-cl

ick "Close", the first and last points are directly connected to close. 

 

 

Figure: Right Angle to Edge - Auto-Close Checked 

 

Figure: Right Angle to Edge - Auto-Close Unchecked 
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Right Angle to Arc: 

If switching to Arc Mode after drawing one point in Right Angle Mode, the drawn v

ectors are cleared. If switching to Arc Mode after drawing two or more points in Rig

ht Angle Mode, all edges are retained, the first drawn point is projected onto the last 

edge as the arc start point, and drawing can continue in Arc Mode. 

Check "Auto-Close": The first point is connected to the last arc end point to close. 

Uncheck "Auto-Close": All edges and confirmed arcs are retained. If using the short

cut key C or right-click "Close", the first and last points are directly connected to clo

se. 

 

 

Figure: Right Angle to Arc - Auto-Close Checked 
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Figure: Right Angle to Arc - Auto-Close Unchecked 

Edge to Vertex: 

If switching to Vertex Mode after drawing one point in Edge Mode, the drawn vector

s are cleared. If switching to Vertex Mode after drawing two or more points in Edge 

Mode, all edges determined by two points are retained, the first drawn point is projec

ted onto the last edge, and drawing can continue in Vertex Mode. 

Check "Auto-Close": The first and last points are connected to close. 

Uncheck "Auto-Close": All edges are retained. If using the shortcut key C or right-c

lick "Close", the first and last points are directly connected to close. 

 

igure: Edge to Vertex - Auto-Close Checked 

 

Figure: Edge to Vertex - Auto-Close Unchecked 

Edge to Right Angle: 
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If switching to Right Angle Mode after drawing one point in Edge Mode, the first po

int is retained as the first point of the first edge in Right Angle Mode for continued 

drawing. If switching to Right Angle Mode after drawing two or more points in Edge

 Mode, all edges determined by two points are retained, and the last edge is used as 

the first edge in Right Angle Mode for continued drawing. 

Check "Auto-Close": The first point is closed by drawing a perpendicular line to the 

last edge. 

Uncheck "Auto-Close": All edges are retained. If using the shortcut key C or right-c

lick "Close", the first and last points are directly connected to close. 

 

Figure: Edge to Right Angle - Auto-Close Checked 

 

Figure: Edge to Right Angle - Auto-Close Unchecked 
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Edge to Arc: 

If switching to Arc Mode after drawing one point in Edge Mode, the drawn vectors a

re cleared. If switching to Arc Mode after drawing two or more points in Edge Mod

e, all edges determined by two points are retained, the first drawn point is projected 

onto the last edge as the arc start point, and drawing can continue in Arc Mode. 

Check "Auto-Close": The first point is connected to the last arc end point to close. 

Uncheck "Auto-Close": All edges and confirmed arcs are retained. If using the short

cut key C or right-click "Close", the first and last points are directly connected to clo

se. 

 

Figure: Edge to Arc - Auto-Close Checked 

 

Figure: Edge to Arc - Auto-Close Unchecked 
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Arc to Vertex: 

When switching to Vertex Mode during Arc Mode drawing, drawing continues along t

he end point of the confirmed arc, and the unconfirmed part of the arc is not retaine

d. 

 

Check "Auto-Close": The first and last points are connected to close. 

 

Uncheck "Auto-Close": Confirmed arcs and all edges are retained. If using the shortc

ut key C or right-click "Close", the first and last points are directly connected to clos

e. 

 

 

Figure: Arc to Vertex - Auto-Close Checked 
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Figure: Arc to Vertex - Auto-Close Unchecked 

Arc to Right Angle: 

When switching to Right Angle Mode during Arc Mode drawing, the end point of th

e confirmed arc is directly used as the first point of the first edge in Right Angle M

ode, and drawing can continue in Right Angle Mode. The unconfirmed part of the ar

c is not retained. 

Check "Auto-Close": The first point is closed by intersecting with the last edge. 

Uncheck "Auto-Close": Confirmed arcs and all edges are retained. If using the shortc

ut key C or right-click "Close", the first and last points are directly connected to clos

e. 

 

 

Figure: Arc to Right Angle - Auto-Close Checked 
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Figure: Arc to Right Angle - Auto-Close Unchecked 

Arc to Edge: 

When switching to Edge Mode during Arc Mode drawing, the end point of the confir

med arc is directly used as the first point in Edge Mode, and drawing can continue i

n Edge Mode. The unconfirmed part of the arc is not retained. 

Check "Auto-Close": When the last edge is determined by two mouse clicks, the firs

t and last points are connected to close; when the last edge is determined by one mo

use click, the first point is closed by intersecting with the extension line of the last p

oint and the tail edge. 

Uncheck "Auto-Close": Confirmed arcs and all edges are retained. If using the shortc

ut key C or right-click "Close", the first and last points are directly connected to clos

e. 
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Figure: Arc to Edge - Auto-Close Checked 

 

Figure: Arc to Edge - Auto-Close Unchecked 

2.4.2.3 Circle 

2.4.2.3.1 Three-Point Circle 

Function Description: 

Draw a circle by determining three points on the circumference in the drawing. 

Operation Steps: 

① Click Draw Vector -> Circle -> Three-Point Circle. 
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Figure: Three-Point Circle 

② In the view, click three points to determine a circle. 

③ During the circle drawing process, right-click and select "Undo Point" to undo on

e point. 

 

Figure: Right-Click Menu for Three-Point Circle 

④ The default drawing mode is "2D Drawing". For a 2D-drawn circle, the plane is 

always parallel to the XY plane of the view, and the vector elevation is consisten

t with the elevation captured by the first point. Select "3D Drawing", and the ref

erence plane of the drawn circle is determined by the three points clicked during 

drawing. 
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⑤ Right-click to switch to "Radius Circle" drawing before performing three-points ci

rcle. 

 

Figure: Right-Click Menu Before Drawing Three-Point Circle 

2.4.2.3.2 Radius Circle 

Function Description: 

Draw a circle by determining the center and radius with two points in the drawing. 

 

Operation Steps: 

① Click Draw Vector -> Circle -> Radius Circle. 
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Figure: Radius Circle 

② In the view, click two points to determine a circle. 

③ During the circle drawing process, right-click and select "Undo Point" to undo on

e point. 

 

Figure: Right-Click Menu for Radius Circle 

④ The default drawing mode is "2D Drawing". For a 2D-drawn circle, the plane is 

always parallel to the XY plane of the view, and the vector elevation is consisten

t with the elevation captured by the first point. Select "3D Drawing", and the dra

wn circle is consistent with the 2D-drawn one. 

⑤ Right-click to switch to "Three-Point Circle" drawing before performing radius cir

cle. 
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Figure: Right-Click Menu Before Drawing Radius Circle 

 

2.4.2.4 Rectangle 

2.4.2.4.1 Two-Point Rectangle 

Function Description: 

Draw a rectangle by clicking two points in the drawing. 

Operation Steps: 

① Click Draw Vector -> Rectangle -> Two-Point Rectangle. 
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Figure: Two-Point Rectangle 

② In the view, click two points to determine a rectangle. 

③ During the rectangle drawing process, right-click and select "Undo Point" to undo

 one point. 

 

Figure: Right-Click Menu for Two-Point Rectangle 

④ The default drawing mode is "2D Drawing". For a 2D-drawn rectangle, the plane 

is always parallel to the XY plane of the view, and the vector elevation is consis

tent with the elevation captured by the first point. A "3D Drawing" rectangle is c

onsistent with the 2D-drawn one. 

⑤ Right-click to switch to "Three-Point Rectangle" drawing before performing two p

oints rectangle. 
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Figure: Right-Click Menu Before Drawing Two-Point Rectangle 

 

2.4.2.4.2 Three-Point Rectangle 

Function Description: 

Draw a rectangle by clicking three points in the drawing. 

 

Operation Steps: 

① Click Draw Vector -> Rectangle -> Three-Point Rectangle. 

 

Figure: Three-Point Rectangle 
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② In the view, click three points to determine a rectangle. 

③ During the rectangle drawing process, right-click and select "Undo Point" to undo

 one point. 

 

Figure: Right-Click Menu for Three-Point Rectangle 

④ The default drawing mode is "2D Drawing". For a 2D-drawn rectangle, the plane 

is always parallel to the XY plane of the view, and the vector elevation is consis

tent with the elevation captured by the first point. Select "3D Drawing", and the 

reference plane of the drawn rectangle is determined by the three points clicked 

during drawing. 

⑤ Right-click to switch to "Two-Point Rectangle" drawing before performing three p

oints rectangle. 
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Figure: Right-Click Menu Before Drawing Three-Point Rectangle 

2.4.2.5 Hatch 

2.4.2.5.1 Pick Internal Point 

Function Description: 

Hatch a closed vector feature with a pattern by clicking inside the closed vector in th

e drawing. 

 

Operation Steps: 

① Click Draw Vector -> Hatch -> Pick Internal Point. The "Create Hatch" panel po

ps up on the right side of the software. 
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Figure: Pick Internal Point 
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Figure: Create Hatch Panel 

② Select the desired pattern style in the "Create Hatch" panel. 

③ Left-click inside the closed vector to be filled. The inside of the vector will be f

illed with the specified pattern style. 

 

The current hatch pattern can be edited in the "Create Hatch" panel. For specific instr

uctions, refer to the "Edit Hatch" section. 
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Figure: Hatch Result 

Note: 

After activating the "Pick Internal Point" hatch command, the patterns hatch continuou

sly at one time will be treated as a single integral object, and editing and modificatio

ns will change the entire object. 

 

2.4.2.5.2 Select Boundary 

Function Description: 

Hatch the closed area formed by multiple vector lines with a pattern by selecting the

m in the drawing. 

 

Operation Steps: 
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① Click Draw Vector -> Hatch -> Select Boundary. The "Create Hatch" panel pops 

up on the right side of the software. 

 

Figure: Select Boundary 
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Figure: Create Hatch Panel 

② Select the desired pattern style in the "Create Hatch" panel. 

③ Left-click select the closed area then Right-click select "OK" to be filled. The ins

ide of the vector will be filled with the specified pattern style. 

 

The current hatch pattern can be edited in the "Create Hatch" panel. For specific instr

uctions, refer to the "Edit Hatch" section. 
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Figure: Hatch Result 

2.4.2.5.3 Draw Boundary 

Function Description: 

Hatch the closed area formed by drawing vector line in the drawing. 

 

Operation Steps: 

① Click Draw Vector -> Hatch -> Draw Boundary. The "Create Hatch" panel pops 

up on the right side of the software. 
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Figure: Draw Boundary 
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Figure: Create Hatch Panel 

② Select the desired pattern style in the "Create Hatch" panel. 

③ Directly draw a vector line, a closed vector will be generated. Press Enter to end,

 or right-click and select "Ok". The inside of the closed vector area will be fille

d with the specified pattern style. 
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The current fill pattern can be edited in the "Create Hatch" panel. For specific instruc

tions, refer to the "Edit Hatch" section. 

 

Figure: Hatch Result 

Note: 

After activating the "Draw Boundary" hatch command, the patterns that are continuous

ly drawn and hatch will be treated as a single integral object, and editing and modifi

cations will chane the entire object. 

 

2.4.2.6 Spline 

Function Description: 

Draw a spline curve in the drawing. 

Operation Steps: 

① Click Draw Vector -> Spline. 
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Figure: Spline Curve 

② In the view window, specify the start point of the spline curve. Move the mouse,

 and a yellow guide line will appear. 

③ In the view window, specify the next point of the spline curve. Continue specifyi

ng points as needed. 
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Figure: Effect of Drawing Spline Curve 

④ In the view window, press Enter to end, or right-click and select "Ok" to comple

te the spline curve drawing. The default spline curve is not closed. To draw a cl

osed spline curve, right-click "Close" to end the drawing, and the spline curve wi

ll be closed. 

⑤ During the spline curve drawing process, right-click and select "Undo" or use the 

shortcut key U to undo one point. 
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Figure: Right-Click Menu for Spline Curve 

2.4.3 Text 

Function Description: 

Draw multiline text in the drawing. 

 

Operation Steps: 

① Click Text. A message is output: Please specify the insertion point of the text. 
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Figure: Text 

 

② Click a point in the view. This point is the insertion point of the text, and the p

lane where the text is located. A message is output: Please specify the direction o

f the text. A preview effect "TEXT" is displayed, and the preview effect rotates 

with the mouse movement. 

③ Click a second point in the view to determine the text direction. A message is o

utput: Please specify the height of the text. The preview effect changes size with 

the mouse movement. 

 

Figure: Preview Effect of Specifying Direction 
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④ Click a third point in the view to determine the text height. A "Text" dialog box 

pops up. Enter the content, click the "Ok" button, close the dialog box, submit th

e result, and do not exit the function. 

 

Figure: Text Input Dialog Box 

 

Figure: Text Output Message 

⑤ In the view, left-click to continue creating text. Repeat the previous step. The ins

ertion point of the text is the mouse click position, and the direction, alignment, a

nd height are the same as before. 

2.4.4 Mark 

2.4.4.1 Aligned Dimension 

Function Description: 
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Dimension point clouds, vectors, and models. The dimension results are saved in the 

current drawing, with two drawing modes: continuous drawing and single drawing. 

 

Continuous Drawing Operation Steps: 

① Click Vector -> Mark -> Aligned Dimension to activate aligned dimensioning. 

 

Figure: Aligned Dimension 

② In the view, click a point as the start position of the aligned dimension. After cli

cking, move the mouse position to display a preview effect for adjusting the leng

th of the dimension line. 

 

Figure: Start Point of Aligned Dimension 

③ In the view, click a second point to determine the length and direction of the di

mension line in the aligned dimension. After clicking, move the mouse position t

o display a preview effect for adjusting the length of the extension line. 
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Figure: Adjusting Extension Line Length of Aligned Dimension 

 

④ In the view, click a third point to determine the length of the extension line. The

 current aligned dimension drawing is completed. After clicking, move the mouse 

to display a preview effect of the next aligned dimension. The end point of the 

current aligned dimension is used as the start point of the next aligned dimensio

n, and the dimension line direction and extension line length of the current aligne

d dimension are retained until pressing Esc or activating another function to exit 

aligned dimension drawing, retaining the completed aligned dimension results. 

 

Figure: Continuously Drawing Aligned Dimensions 

Single Drawing Operation Steps: 

① Click Vector -> Mark -> Aligned Dimension to activate aligned dimensioning. 

② In the view, right-click and click the "Single Drawing" option in the right-click 

menu to switch to single drawing of aligned dimensions. 
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Figure: Switch to Single Aligned Dimension 

③ In the view, sequentially select the start point, end point, and extension line lengt

h of the aligned dimension to complete the single aligned dimension drawing. 

④ In the view, continue left-clicking to start the next single aligned dimension draw

ing. 

2.4.4.2 Area Dimension 

Function Description: 

Dimension the area of a closed 2D area through three methods: picking an internal p

oint, selecting boundary lines, and drawing boundary lines. 

 

Picking Internal Point Operation Steps: 

① Click Vector -> Mark -> Area Dimension to activate area dimensioning. A param

eter panel appears on the right side of the software. 
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Figure: Area Dimension 
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Figure: Area Dimension Parameter Panel 

② Select "Pick Internal Point" in the parameter panel, then click a point inside the 

2D closed area to complete the area dimensioning. 

 

Figure: Area Dimension by Picking Internal Point 

Selecting Boundary Lines Operation Steps: 

① Click Vector -> Mark -> Area Dimension to activate area dimensioning. 

② Select "Select Boundary Lines" in the parameter panel, then select the vector line

s that form the closed area to be dimensioned in the view. Press Enter or right-cl

ick "Ok" to complete the area dimensioning. 
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Figure: Area Dimension by Selecting Boundary Lines 

 

Drawing Boundary Lines Operation Steps: 

③ Click Vector -> Mark -> Area Dimension to activate area dimensioning. 

④ Select "Draw Boundary Lines" in the parameter panel, then draw a 2D closed ve

ctor in the view. After drawing three points, right-click "Ok" or Press Enter/Doubl

e-click to end the drawing and complete the area dimensioning. 
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Figure: Area Dimension by Drawing Boundary Lines 

2.4.4.3 Elevation Dimension 

Function Description: 

Click a point in the view to create an elevation dimension at the clicked position in 

an absolute or relative manner. 

 

Absolute Elevation Operation Steps: 

 

① Click Vector -> Mark -> Elevation Dimension to activate elevation dimensioning. 
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Figure: Elevation Dimension 

② A parameter panel for elevation appears on the right side of the software. The "

Absolute" elevation mode is selected by default. A message is outputted: Entered 

absolute elevation mode. Please click in the view to draw the elevation. 

 

 

Figure: Elevation Parameter Panel 
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③ Click a point in the view to determine the position of the elevation dimension. 

④ Click a second point to determine the direction of the elevation dimension. 

 

Figure: Absolute Elevation 

Relative Elevation Operation Steps: 

① Click Vector -> Mark -> Elevation Dimension to activate elevation dimensioning. 

② A parameter panel for elevation appears on the right side of the software. Select 

"Relative" in the parameter panel. A message is outputted: Entered relative elevati

on mode. Please set the starting elevation first, then click in the view to draw the

 elevation. 
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Figure: Elevation Parameter Panel 

③ In the view, pick a point through the interaction button or manually enter the sta

rting elevation. 

④ In the view, click a point to determine the position of the elevation dimension. 

⑤ In the view, click a second point to determine the direction of the elevation dime

nsion. 
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Figure: Relative Elevation 

2.4.5 Dimension Style 

2.4.5.1 Line 

Function Description: 

Set the drawing method of extension lines in aligned dimensions, which can be set to

 fixed extension line length or non-fixed extension line length. When in fixed extensio

n line length, the length of the fixed extension line can be entered. The settings take 

effect for subsequent aligned dimension drawings and are invalid for existing aligned 

dimension results. 

 

Operation Steps: 

 

① Click Vector -> Mark->Dimension Style. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

263 

 

Figure: Dimension Style 

 

② Click "Line" to enter the line style management interface. 

 

Figure: Line Setting Interface 

③ Check "Fixed Length" and set the extension line 
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Figure: Check Fixed Extension Line Length 

When the interactive extension line length is less than the set fixed extension line len

gth value, the aligned dimension is completed according to the interactive extension li

ne length; when the interactive extension line length is greater than the set fixed exte

nsion line length value, the length of the extension line is the set fixed extension line

 length value. 

 

Figure: Fixed Extension Line Result 
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2.4.5.2 Arrow 

Function Description: 

Set the style of arrows in aligned dimensions. After modification and application, it ta

kes effect for subsequent aligned dimension drawings and is invalid for existing aligne

d dimension results. 

 

Operation Steps: 

① Click Vector -> Mark ->Dimension Style. 

② Click Arrow to enter the arrow management interface. 

 

 

Figure: Arrow Setting Interface 
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③ Click the drop-down box of arrow type, select different styles, and the arrow typ

e of the dimension will be modified to the corresponding style. 

 

Figure: Select Arrow Style 
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Figure: Modified Arrow Style Result 

2.4.5.3 Text 

Function Description: 

Set the alignment, horizontal position, vertical position, and height effect of text in ali

gned dimensions. After modification and application, it takes effect for subsequent alig

ned dimension drawings and is invalid for existing aligned dimension results. 

 

Operation Steps: 

① Click Vector ->Mark-> Dimension Style. 

② Click Text to enter the text management interface. 

 

Figure: Text Setting Interface 
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③ Click the drop-down box of "Aligned". When the mouse is in the aligned drop-d

own box, the preview effect of the text alignment type will change with the mou

se selection. After clicking an option in the drop-down box, the alignment type 

will be changed to the selected one. 

 

Figure: Select Alignment Method 

 

④ Click the drop-down box of "Horizontal" and select an option in the drop-down 

box to modify the text position in the dimension to the corresponding style. 
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Figure: Select Text Horizontal Position 

 

⑤ Click the drop-down box of "Vertical" and select an option in the drop-down box

 to modify the text position in the dimension to the corresponding style. 
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Figure: Select Text Vertical Position 

 

⑥ Click the input box of "TextHeight". The text height can be adjusted in three wa

ys: inputting, scrolling the mouse wheel, and adjusting buttons. 
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Figure: Result After Modifying Text Settings and Application 

 

2.4.5.4 Display Unit 

Function Description: 

Set the unit and precision of the dimension results in aligned dimensions. After modif

ication and application, it takes effect for subsequent aligned dimension drawings and 

is invalid for existing aligned dimension results. 

 

Operation Steps: 

① Click Vector ->Mark -> Dimension Style. 

② Click Unit to enter the unit management interface. 
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Figure: Unit Setting Interface 

③ In unit interface, the display unit and accuracy can be modified. When modifying

 the accuracy option, the preview effect will be refreshed in real time. 
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Figure: Accuracy Adjustment 

 

Figure: After Modifying Accuracy 

2.4.6 Edit 

2.4.6.1 Copy 

Function Description: 

Copy the selected vector to the specified position in the drawing. 

 

Operation Steps: 

① Click Vector -> Edit -> Copy. 
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Figure: Copy 

② In the view, select the vector to be copied (multiple selections are supported), an

d click the right-click menu "Ok" or press the shortcut key Enter to confirm the 

selection set. 

③ In the view, click a point to specify the base point. 

④ Move the mouse position and click again to copy the vector to the specified posi

tion, supporting continuous copying. 

 

Figure: Copy Vector 
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Note: The copy function supports selecting the vector first, then clicking the copy b

utton. The selected vector will be used as the copy object, and copying can be start

ed after selecting the base point. 

2.4.6.2 Move 

Function Description: 

Move the selected vector to the specified position in the drawing. 

 

Operation Steps: 

① Click Vector -> Edit -> Move. 

 

 

Figure: Move 

② In the view, select the vector to be moved (multiple selections are supported), an

d click the right-click menu "Ok" or press the shortcut key Enter to confirm the 

selection set. 

③ In the view, click a point to specify the base point. 

④ Move the mouse position and click again to move the vector to the specified pos

ition. 
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Figure: Move Vector 

 

Note: The move function supports selecting the vector first, then clicking move. Th

e selected vector will be used as the move object, and the vector can be moved afte

r selecting the base point. 

2.4.6.3 Close 

Function Description: 

Connect the first and last points of the selected non-closed polyline to close it in the 

drawing. 

 

Operation Steps: 

① Click Vector -> Edit -> Close. 
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Figure: Close 

② In the view, select the polyline to be closed, and the first and last points of the 

polyline will be connected to close it. 

 

Figure: Close Result 

2.4.6.4 Break 

2.4.6.4.1 Break At Point 

Function Description: 

Select a vector in the drawing, specify a point, and break the vector from the specifie

d position. 

 

Operation Steps: 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

278 

① Click Vector -> Edit -> Break -> Break At Point. 

 

Figure: Break At Point 

② In the view, select the vector to be broken. 

③ Click a point on the selected vector to specify the break position, and the vector 

will be broken from the specified position. 

 

Figure: Single-Point Break Result 

2.4.6.4.2 Two-Point Break 

Function Description: 

Select a vector in the drawing, specify two points, and break the vector between the t

wo points. 

 

Operation Steps: 
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① Click Vector -> Edit -> Break -> Break. 

 

Figure: Break 

② In the view, click to select the vector to be broken. 

③ Click another point on the selected vector to specify the break position, and the 

vector will be broken between the two points. 

 

Figure: Two-Point Break Result 

2.4.6.5 Extend 

 

2.4.6.5.1 Standard Extend 

Function Description: 
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Extend the vector in the drawing to the specified reference object. 

 

Operation Steps: 

① Click Vector -> Edit -> Extend -> Standard Extend. 

 

Figure: Standard Extend 

② In the view, select the reference object first (multiple selections are supported), a

nd click the right-click menu "Ok" or press the shortcut key Enter to confirm the

 selection. 

③ In the view, click to select the vector to be extended, and the vector will be ext

ended to the reference object , supporting multiple extensions. 

 

Figure: Standard Extend Result 
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Note: Standard extend supports selecting the vector first, then clicking the standard

 extend button. The selected vector will be used as the reference object, and the ex

tend function can be used. 

2.4.6.5.2 Quick Extend 

Function Description: 

Extend the vector in the drawing to the nearest vector object. 

Operation Steps: 

① Click Vector -> Edit -> Extend -> Quick Extend. 

 

Figure: Quick Extend 

 

② In the view, click to select the vector to be extended, and the vector will be ext

ended to the nearest vector object, supporting multiple extensions. 
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Figure: Quick Extend Result 

2.4.6.6 Trim 

2.4.6.6.1 Standard Trim 

Function Description: 

After selecting the reference object, trim off the part of the vector object in the drawi

ng that intersects with the reference object. 

 

Operation Steps: 

① Click Vector -> Edit -> Trim -> Standard Trim. 

 

Figure: Standard Trim 
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② In the view, select the reference object (multiple selections are supported), and cli

ck the right-click menu "Ok" or press the shortcut key Enter to confirm the select

ion set. 

③ In the view, click to select the part of the vector object that intersects with the r

eference object and needs to be trimmed, and that part of the vector object will b

e trimmed off, supporting multiple trims. 

 

Figure: Standard Trim Result 

 

Note: Standard trim supports selecting the vector first, then clicking the standard t

rim button. The selected vector will be used as the reference object, and the standa

rd trim function can be used. 

2.4.6.6.2 Quick Trim 

Function Description: 

Select a vector object in the drawing and trim off a part of the vector object from th

e intersection. 

 

Operation Steps: 

① Click Vector -> Edit -> Trim -> Quick Trim. 
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Figure: Quick Trim 

② In the view, click to select the part of the vector object that needs to be trimme

d, and that part of the vector object will be trimmed off from the intersection, su

pporting multiple trims. 

 

 

Figure: Quick Trim Result 

2.4.6.7 Rotate 

Function Description: 

Rotate the selected vector to the specified position in the drawing. 
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Operation Steps: 

① Click Vector -> Edit -> Rotate, and a parameter panel appears on the right side 

of the software. 

 

Figure: Rotate 
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Figure: Rotate Parameter Panel 

 

② In the view, select the vector to be rotated (multiple selections are supported), an

d click the right-click menu "Ok" or press the shortcut key Enter to confirm the 

selection set. 

③ In the view, click a point to specify the base point. 

④ Move the mouse position, determine the angle and click again, or select "Paramet

er" in the parameter panel, enter the angle value and click the "Ok" button to rot

ate the vector to the specified position. 
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Figure: Rotate Vector 

 

Parameter Settings: 

Angle (°): The angle value by which the vector rotates counterclockwise around the b

ase point, with a setting range of [0, 360]. 

 

Note: The rotate function supports selecting the vector first, then clicking the rotate

 button. The selected vector will be used as the rotate object, and the vector can b

e rotated after selecting the base point. 

2.4.6.8 Offset 

Function Description: 

Select the vector to be offset, and use interactive or parameter methods to offset the 

selected vector in the specified direction and distance for a single or continuous offset

 to generate a new vector. 

 

Operation Steps: 
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① Click Vector ->Edit ->Offset to activate offset. 

 

 

Figure: Offset Button 

② A parameter panel for offset appears on the right side of the software. 
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Figure: Offset Parameter Panel 

③ In the view, select the vector to be offset (only single selection is supported). Th

e parameter panel defaults to "Interactive" mode and "Single Offset". 

In "Interactive" mode, "Single Offset" performs one offset on the currently selected ve

ctor, and after offsetting, you need to select the vector again for offsetting; if "Contin
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uous Offset" is selected, multiple offsets can be performed continuously on the current

ly selected vector. 

 

Figure: Offset Preview 

 

④ Move the mouse position, determine the position and click again, or select "Para

meter" in the parameter panel, enter the "direction, distance and times" of the off

set and click the "Ok" button to generate the offset vector at the specified positio

n. 
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Figure: Offset Result 

 

Note: The offset function supports selecting a single offsettable vector first, then clicki

ng the offset button. The selected vector will be used as the reference object, and the

 offset function can be used. 

2.4.6.9 Array 

Function Description: 

Select the vector to be arrayed, modify the number of rows and columns, row spacin

g, and column spacing, and click "Ok" to create copies distributed in a rectangle. 

 

Operation Steps: 

① Click Vector ->Edit ->Array to activate array. Output message: Please set the nu

mber of rows and columns, row spacing, and column spacing in the parameter pa

nel. 
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Figure: Array 

② A parameter panel for array appears on the right side of the software. 

 

 

Figure: Array Parameter Panel 
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③ In the view, select the vector to be arrayed (multiple selections are supported), an

d click the right-click menu "Ok" or press the shortcut key Enter to confirm the 

selection set. 

④ Set parameters, manually enter the number of rows and columns, row spacing, an

d column spacing, or click the button next to the parameter to interactively specif

y the number of rows and columns, row spacing, and column spacing in the vie

w. 

⑤ Click "Ok" to submit the array result. 

 

 

Figure: Array Effect 

 

Note: The array function supports selecting the vector first, then clicking the array 

button. The selected vector will be used as the array object, and the array function

 can be used. 

2.4.6.10 Elevation Edit 

Function Description: 

Modify the elevation value of the selected vector in the relative value or absolute val

ue. 

Operation Steps: 
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① Click Vector ->Edit ->Elevation Edit to activate elevation edit. Output message: P

lease select the vector whose elevation needs to be modified, click the right-click 

menu "Ok" or shortcut key Enter to end the selection. 

 

Figure: Elevation Edit 

 

② In the view, select the vector whose elevation needs to be modified (multiple sele

ctions are supported), and click the right-click menu "Ok" or press the shortcut k

ey Enter to confirm the selection set. Output message: Please set the modification

 method and elevation value in the parameter panel. 

 

 

Figure: Output Message 

③ Set parameters. Select "Relative Value" to modify relative to the original elevation

 of the vector; select "Absolute Value" to directly modify the vector to the set el

evation. 
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Figure: Relative Value Preview Effect 

 

Figure: Absolute Value Preview Effect 

④ Click "Ok" to submit the elevation modification result. 

Note: The elevation modification function supports selecting the vector first, then cl

icking the elevation modification button. The selected vector will be used as the ele

vation modification object, and the elevation modification function can be used. 
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2.4.6.11 Add Vertex 

Function Description: 

Add vertices to existing polyline, 3D polyline, and arc elements. 

 

Operation Steps: 

 

① Click Vector ->Edit-> Add Point. 

 

Figure: Add Point 

② In the view, select the vector to add points (multiple selections are supported), an

d click the right-click menu "Ok" or press the shortcut key Enter to confirm the s

election set. 

③ Left-click on the selected vector to add a vertex at the clicked position. 

④ You can exit the add point function by double-clicking the left mouse button/right

-clicking to cancel/Esc. 

2.4.6.12 Delete Vertex 

Function Description: 

Delete vertices when the existing polyline or 3D polyline has more than two vertices. 

Operation Steps: 

① Click Vector ->Edit-> Delete Point. 
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Figure: Delete Point 

② In the view, select the required vector (multiple selections are supported), and cli

ck the right-click menu "Ok" or press the shortcut key Enter to confirm the selec

tion set. 

③ Left-click the vertex of the selected vector. If the selected vector is a polyline or 

3D polyline with more than two vertices, the selected vertex will be deleted; othe

rwise, the vertex will not change. 

④ You can exit the delete point function by double-clicking the left mouse button/ri

ght-clicking to cancel/Esc. 

2.4.6.13 Move Point 

Function Description: 

Move existing vector nodes. 

 

Operation Steps: 

① After selecting the vector, click the intersection point of the vector. When the int

ersection point turns red, move the mouse position, and the vertex position will m

ove with the mouse. 
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Figure: Move Point 

② Select the target position in the view and left-click the mouse to complete the po

int movement. 

③ The point moving operation does not need to be exited manually. 

1. 2.4.6.14 Align 

Function Description: 

Move and rotate the selected vector based on two origin points and target points. 

Operation Steps: 

① Click Vector -> Edit -> Align. 

 

Figure: Align 
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② In the view, select vectors that need to be aligned (support selecting multiple vecto

rs), click the right-click menu "Ok" or press the shortcut key Enter to end the sel

ection. 

③  Click with the left mouse to select the "Origin Point1" and "Target Point1", then 

"Origin Point2" and "Target Point2". The selected vector will be moved and rotate

d according to the selected origin points and target points. 

 

Figure: Select Points to Align 
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Figure: Effect of Alignment 

④ Double-click the left mouse/Right-click and select"Cancel"/ESC to exit the align fun

ction. 

Note: 

The two sets of points are not allowed to overlap. 

2.4.6.15 Advanced 

2.4.6.15.1 Unite 

Function Description: 

Merge multiple selected vectors into one vector in the drawing. 

 

Operation Steps: 

① Click Vector -> Edit -> Advanced -> Unite. 
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Figure: Unite 

② In the view, select multiple vectors with connected endpoints (support selecting m

ultiple groups of vectors to merge respectively), and multiple vectors can be merg

ed into one vector element. Continuous merging is supported. 

 

Figure: Merge Vector 

 

Note: 

Only vectors with connected endpoints can be merged into one vector element. In a

ddition, collinear lines can be merged into a single line, and arcs on the same circl

e can be merged into a single arc or circle. 

 

Objects that do not support merging are: 
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1. Curved objects such as splines, elliptical arcs, and spirals. 

2. Currently, arcs and 3D polylines are not supported for merging. 

 

Note: The merge function supports selecting mergeable vectors first, then clicking t

he merge button to merge the selected vectors. 

2.4.6.15.2 Split 

Function Description: 

Draw a split line to split the selected vector into multiple parts. 

 

Operation Steps: 

① Click Vector -> Edit ->Advanced -> Split to activate split. Output message: Pleas

e select the split element first, click the right-click menu "Ok" or press the short

cut key Enter to end the selection. 

 

Figure: Split 

② In the view, select the vector to be split (multiple selections are supported), and 

click the right-click menu "Ok" or press the shortcut key Enter to confirm the se

lection set. 

③ Set parameters. Select "Only Split" to cut the object into multiple parts via clicki

ng two point on the selected object; select "Generate New entities" to generate n

ew entities via creating a split line from the split object. 
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④ Draw a polyline to split the entities, double-click to end and the split takes effec

t. The selection set can be split multiple times. 

 

Figure: Split Only Result 

 

Figure: Generate New Entites Split Result 
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Note: 

Objects that cannot be split are: points, blocks, groups, text, dimensions, and table

s. 

 

The split function supports selecting the vector first, then clicking the split button. Th

e selected vector will be used as the split object, and the split function can be used. 

2.4.6.16 Vector Selection 

2.4.6.16.1 Single Selection 

Function Description: 

Click to select the vector elements displayed in the view window. 

 

Operation Steps: 

① Use the left mouse button to click the vector in the view. 

② When the clicked vector is in the active drawing and in an unlocked layer, the s

ingle selection effect is that the vector is highlighted and the points on the vecto

r are displayed. 

 

 

Figure: Single Selection 

③ When the single-selected vector is in a non-active drawing or in a locked layer o

f the active drawing, the single selection effect is that the vector is highlighted, a

nd the points on the vector are not displayed. 
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Figure: Single Selection of Vector in Non-Active Drawing or Locked Layer of Active 

Drawing 

2.4.6.16.2 Selection Vector - Left to Right 

① Function Description: 

Draw a selection area from left to right, and use the selection area to completely

 cover the vectors in the view. The covered vectors are selected. 

 

Operation Steps: 

② Use the left mouse button to click a point on the left side of the vector, move t

he mouse to the right to draw a selection area, so that the selection area complet

ely covers the vector elements to be selected. 
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Figure: Selection Vector from Left to Right 

③ Left-click the mouse to end the selection. When the vectors completely covered b

y the selection area are in the unlocked layer of the active drawing, the single se

lection effect is that the vectors are highlighted and the points on the vector are 

displayed; otherwise, only highlighted without displaying points. 

2.4.6.16.3 Selection Vector- Right to Left 

④ Function Description: 

Draw a selection area from right to left, and use the selection area to partially or

 completely cover the vectors in the view. The covered vectors are selected. 

 

Operation Steps: 

 

⑤ Use the left mouse button to click a point on the right side of the vector, move 

the mouse to the left to draw a selection area, so that the selection area partially

 or completely covers the vector elements to be selected. 
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Figure:Selection Vector from Right to Left 

① Left-click the mouse to end the selection. When the vectors partially or completel

y covered by the selection area are in the unlocked layer of the active drawing, t

he single selection effect is that the vectors are highlighted and the points on the 

vector are displayed; otherwise, only highlighted without displaying points. 

2.4.6.16.4 Deselection 

② Function Description: 

Change a currently selected vector to an unselected state. 

 

Operation Steps: 

③ Shift + Single Selection: Hold down Shift, use the left mouse button to click the

 currently selected vector, and the vector will be deselected. 
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Figure: Deselection + Single Selection 

④ Shift + Selection vector from Left to Right: Hold down Shift, use the left mouse

 button to click and drag to the right to window select. After the window selectio

n range completely covers the selected vectors, left-click the mouse to end the wi

ndow selection, and the selected vectors range will be deselected. 
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Figure: Deselection + Selection vector from Left to Right 

⑤ Shift + Window Selection from Right to Left: Hold down Shift, use the left mou

se button to click and drag to the left to window select. After the window selecti

on range partially or completely covers the selected vectors, left-click the mouse t

o end the window selection, and the selected vectors partially or completely cover

ed by the window selection range will be deselected. 
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Figure: Deselection + Selection vector from Right to Left 

2.4.6.17 Edit Hatch 

Function Description: 

Only when the hatch pattern is selected, the hatch edit panel pops up on the right sid

e of the software, and the selected hatch pattern can be edited. 

 

Operation Steps: 

① Click to select the hatch pattern in the active drawing, and the "Edit Hatch" pane

l appears on the right side of the software. 
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Figure: Edit Hatch Panel 

② In the edit hatch panel, you can modify the style, color, background color, transp

arency, angle, and pattern scale attributes of the selected hatch vector. 

Parameter Settings: 
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Scale: The scale of the hatch pattern, default is 1 (Standard). The larger the value, th

e sparser the hatch pattern display; the smaller the value, the denser the hatch pattern 

display. 

2.4.7 Layer 

Function Description: 

Layer management can view the layer's name, group, color, line type, line width, num

ber of elements, transparency, description, display whether the vector is set to current, 

closed, frozen, and locked. 

 

Operation Steps: 

① Keep the layer manager existing in the software; 

② Click the layer button to pop up the layer manager dialog box; 

 

Figure: Open Layer Manager 

③ In the layer manager, you can create a new layer, delete a layer, set as current, 

delete all layers except layer 0, select all elements in the selected layer, clear all 

elements in the selected layer, select empty layers, display empty layers, rename l

ayers, open/close layers, freeze/thaw layers, lock/unlock layers. 
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Figure: Layer Manager List 

2.4.7.1 Layer Manager 

Function Description: 

The functions above the layer list from left to right are: New Layer, Delete Layer, A

ctivate Layer, Delete All Layers Except Layer 0, Select All Entities in Selected Layer,

 Clear All Entities in Selected Layer, Show Empty Layers. 

 

Figure: Layer Manager 

 

Operation Steps: 

Left-click the button to implement the corresponding function. 

2.4.7.1.1 New Layer 

Function Description: 

Create a new layer. 
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Figure: New Layer 

 

Operation Steps: 

Left-click New Layer, and the new layer is created at the bottom of the layer list. 

2.4.7.1.2 Delete Layer 

Function Description: 

Delete an existing layer. 

 

Figure: Delete Layer 
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Operation Steps: 

Select the layer in the list, left-click Delete Layer, select OK in the pop-up message 

window, and the selected layer is deleted (layer 0 and the current layer cannot be del

eted). 

2.4.7.1.3 Activate Layer 

Function Description: 

Set a non-current layer as the current layer. 

 

Figure: Activate Layer 

 

Operation Steps: 

Select the layer in the list, left-click Acticate Layer, the selected layer is set as the c

urrent layer, and the status of the layer becomes checked. 

2.4.7.1.4 Delete All Layers Except For Layer 0 

Function Description: 

Delete all layers except layer 0 and the current layer. 
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Figure: Delete All Layers Except Layer 0 and Current Layer 

 

Operation Steps: 

Left-click the Delete All Layers Except Layer 0 button, select Yes in the pop-up mess

age window, and layers other than the current layer and layer 0 are deleted. 

2.4.7.1.5 Select All Entities in Selected Layer 

Function Description: 

Select all elements in the selected layer. 
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Figure: Select All Entities in Selected Layer 

Operation Steps: 

Select the layer in the list, left-click the Select All Entities in Selected Layer button, 

and all elements in the layer are selected. 

2.4.7.1.6 Clear All Entities in Selected Layer 

Function Description: 

Delete all elements in the selected layer. 

 

Figure: Clear All Entities in Selected Layer 

 

Operation Steps: 

Select the layer in the list, left-click the Clear All Entities in Selected Layer button, a

nd all elements in the layer are deleted. 

2.4.7.1.7 Show Empty Layer 

Function Description: 

Display layers with 0 elements in the drawing (layer 0 will not be hidden). 
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Figure: Show Empty Layer 

 

Operation Steps: 

Left-click to check the Show Empty Layers checkbox to display layers with 0 elemen

ts in the drawing. 

2.4.7.2 Right-Click Menu of Layer List 

Function Description: 

The functions of the right-click menu of the layer list from top to bottom are: Show 

Empty Layers, Activate Layer, New Layer, Rename Layer, Delete Layer, Freeze All L

ayers, Unfreeze All Layers, Open All Layers, Close All Layers, Select Empty Layers, 

Select Non-Empty Layers, Select Layer Entities, Clear Layers, Clear Selected Layer E

ntities. 
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Figure: Right-Click Menu of Layer List 

 

Operation Steps: 

Right-click the layer list to pop up the menu, and left-click to select the function to 

execute. 

2.4.7.2.1 Show Empty Layers 

Function Description: 

Display layers with 0 elements in the drawing. 
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Figure: Show Empty Layers 

 

Operation Steps: 

Left-click Show Empty Layers to display layers with 0 elements in the drawing. 

2.4.7.2.2 Activate Layer 

Function Description: 

Set a non-current layer as the current layer. 

 

Figure: Activate Layer 

 

Operation Steps: 

Select the layer in the list, right-click to pop up the menu, left-click Select Set as Cu

rrent, and the status of the layer becomes checked (when the current layer is selected 

by right-click, the Activate Layer in the right-click menu is disabled). 
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2.4.7.2.3 New Layer 

Function Description: 

Create a new layer. 

 

 

Figure: New Layer 

 

Operation Steps: 

Left-click Select New Layer, and the new layer is created at the bottom of the layer 

list. 

2.4.7.2.4 Rename Layer 

Function Description: 

Rename the layer. 
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Figure: Rename Layer 

 

Operation Steps: 

Select the layer to be renamed, right-click to pop up the menu, select Rename Layer, 

the layer name becomes editable, and you can enter a name to rename the layer. 

2.4.7.2.5 Delete Layer 

Function Description: 

Delete an existing layer. 

 

Figure: Delete Layer 

 

Operation Steps: 

Select the layer in the list, right-click to pop up the menu, left-click Delete Layer, sel

ect OK in the pop-up message window, and the selected layer is deleted. 

2.4.7.2.6 Freeze All Layer 

Function Description: 

Freeze all layers except the current layer. 
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Figure: Freeze All Layer 

 

Operation Steps: 

Right-click in the layer list to pop up the menu, left-click Freeze All Layer, all layers

 except the current layer are frozen, and the freeze column attribute becomes a gray s

nowflake. 

2.4.7.2.7 Unfreeze All Layer 

Function Description: 

Unfreeze all layers. 

 

 

Figure: Unfreeze All Layer 

 

Operation Steps: 

Right-click in the layer list to pop up the menu, left-click Unfreeze All Layer, all lay
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ers are unfreezed, and the freeze column attribute becomes an orange sun. 

2.4.7.2.8 Open All Layer 

Function Description: 

Open all layers. 

 

Figure: Open All Layer 

 

Operation Steps: 

Right-click in the layer list to pop up the menu, left-click Open All Layer, all layers 

are opened, and the open column attribute becomes an orange light bulb. 

2.4.7.2.9 Close All Layer 

Function Description: 

Close all layers. 
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Figure: Close All Layer 

 

Operation Steps: 

Right-click in the layer list to pop up the menu, left-click Close All Layer, all layers 

are closed, and the open column attribute becomes a gray light bulb. 

2.4.7.2.10 Select Empty Layer 

Function Description: 

Select all empty layers. 

 

Figure: Select Empty Layer 

 

Operation Steps: 

Right-click in the layer list to pop up the menu, left-click Select Empty Layer, and al

l empty layers are selected. 

 

Note: You need to check the Show Empty Layer first. 

2.4.7.2.11 Select Non-Empty Layer 

Function Description: 

Select all non-empty layers. 
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Figure: Select Non-Empty Layer 

 

Operation Steps: 

Right-click in the layer list to pop up the menu, left-click Select Non-Empty Layers, 

and all non-empty layers are selected. 

2.4.7.2.12 Select Layer Entities 

Function Description: 

Select all elements in the selected layer. 
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Figure: Select Layer Entities 

Operation Steps: 

Select the layer in the list, left-click the "Select Layer Entities" button, and all elemen

ts in the layer will be selected. 

 

2.4.7.2.13 Clear Layer 

Function Description: 

Deletes all layers except Layer 0 and the current layer. 
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Figure: Clear Layer 

Operation Steps: 

Right-click in the layer list to open the context menu, left-click the "Clear Layer" but

ton, select "Yes" in the pop-up message window, and all layers except the current lay

er and Layer 0 will be deleted. 

2.4.7.2.14 Clear Selected Layer Entities 

Function Description: 

Delete all elements in the selected layer. 

 

 

Figure: Clear Selected Layer Entities 

Operation Steps: 

Select the layer in the list, right-click to bring up the menu, and left-click the "Clear 

Selected Layer Entities" button to delete all elements in the layer. 

2.4.7.3 Layer Drop-down Box 

Function Description: 

Quickly modify the current layer and the switch, freeze, lock status of the layer throu

gh the layer drop-down box in the layer menu, and also set the layer color. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

329 

 

Figure: Layer Drop-down Box 

 

Operation Steps: 

Left-click the layer drop-down box in the layer toobar to display the list. 

2.4.7.3.1 Switch 

Function Description: 

Quickly adjust the on/off status of a certain layer during vector drawing and editing. 

Operation Steps: 

Click Vector -> Layer Drop-down Box -> Layer Switch Button to adjust the on/off st

atus of the corresponding layer. 

When the button is orange highlighted, it indicates that the layer is currently in the e

nabled state; when the button is not highlighted, it indicates that the layer is currently

 in the disabled state. When the layer is disabled, all vectors in the layer are invisibl

e and unselectable in the view window, but vectors can be modified to the disabled l

ayer through the property panel, and the disabled layer can also be set as the current 

layer. 
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Figure: Layer On/Off in Layer Drop-down Box 

 

2.4.7.3.2 Freeze 

Function Description: 

Quickly adjust the freeze status of a certain layer during vector drawing and editing. 

Operation Steps: 

Click Vector -> Layer Drop-down Box -> Layer Freeze Button to adjust the unfrozen 

and frozen status of the corresponding layer. 

When the button is an orange sun, it indicates that the layer is currently in the unfro

zen state; when the button is a grey snowflake, it indicates that the layer is currently 

in the frozen state. When the layer is frozen, all vectors in the layer are invisible and

 unselectable in the view window, and vectors cannot be modified to the frozen layer 

through the property panel, and the current layer cannot be frozen. 
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Figure: Layer Freeze in Layer Drop-down Box 

 

2.4.7.3.3 Lock 

Function Description: 

Quickly adjust the lock status of a certain layer during vector drawing and editing. 

Operation Steps: 

Click Vector -> Layer Drop-down Box -> Layer Lock Button to adjust the unlocked 

and locked status of the corresponding layer. 

When the button is an orange unlocked lock, it indicates that the layer is currently in

 the unlocked state; when the button is a dark locked lock, it indicates that the layer 

is currently in the locked state. When the layer is locked, all vectors in the layer are 

visible (with darker colors) and selectable in the view window. The locked layer can 

also be set as the current layer, but vectors cannot be modified to the locked layer th

rough the property panel. 
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Figure: Layer Lock in Layer Drop-down Box 

2.4.7.3.4 Color 

Function Description: 

Quickly adjust the color attribute of a certain layer during vector drawing and editing. 

Operation Steps: 

Click Vector -> Layer Drop-down Box -> Color, and after the color picker pops up, s

elect the desired color in the color picker and click OK, and the corresponding layer 

will change to the modified color. 

 

Figure: Layer Color in Layer Drop-down Box 
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Figure: Color Picker 

 

2.4.7.3.4 Current Layer 

Function Description: 

Quickly adjust the current layer during vector drawing and editing. 

Operation Steps: 

Click Vector -> Layer Drop-down Box -> Layer Name, and click the layer name posi

tion to set the clicked layer as the current layer (a frozen layer cannot be set as the 

current layer), and new vectors will be drawn in the current layer.
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Figure: Set as Current Layer 

2.4.8 Template 

2.4.8.1 Block 

Function Description: 

Use existing templates to draw in the drawing. 

Operation Steps: 

① Click Vector -> Template -> Block to pop up the block table panel, and click to s

elect a template 

 

Figure: Block Template 
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Figure: Block Table Panel 

① Select the drawing mode in the block table panel. By default, rotation and scale ar

e set to "Interactive" mode, and the scale ratio is set to "Unitary". 
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Figure: Default Option Settings 

① Click a point in the view as the insertion point of the block. 

 

Figure: Insertion Point of the Block 

① Move the mouse to adjust the rotation angle, and click a point to determine the ro

tation angle of the block. If the "Parameter" mode is selected, the preset angle value 

will be directly used as the rotation angle of the block without adjustment in the vie

w. 
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Figure: Adjust Rotation Angle 

① Move the mouse to adjust the scaling ratio, and click a point to determine the scal

ing ratio of the block to complete the block drawing. If the "Parameter" mode is sele

cted, the set X and Y scaling ratios will be directly used as the scaling ratios of the 

block without adjustment in the view. 
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Figure: Adjust Scale 

 

Figure: Completion 

Parameter Settings: 

Unitary Scale: The scaling ratios in the X and Y directions of the block is always 

1:1. When the value of any attribute in X or Y is modified, the other value will cha
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nge accordingly, and the positive or negative value only represents the direction of the

 block. 

Respective Scale: When "Respective Scale" is selected, the scaling ratios in the X o

r Y direction of the block can be set separately, and there is no synchronous change 

relationship between X and Y, and the positive or negative value only represents the 

direction of the block. 

When the rotation angle is 0°, the relationship between the direction of the block and 

the positive/negative values of the X and Y scaling ratios is as shown in the followin

g figure: 

 

Figure: Direction of the Block 

 

Repeat Placement: By default, "Repeat Placement" is not checked, and the drawing ex

its after drawing one block; if "Repeat Placement" is checked, after drawing one bloc

k, the rotation angle and scaling ratio of the block are retained, and you can continue

 to select only the insertion point in the view to repeatedly draw the same block. 

Note: 
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When drawing a block, you need to set the options in the block table panel 

first, and then draw the block in the view. After the mouse moves to the vie

w, the setting options in the block table panel will be grayed out. To modify

 the setting options, you need to reselect the block template and set it again. 

2.4.8.2 Line 

Function Description: 

Select the desired line style to draw polylines. 

Operation Steps: 

① Click Vector -> Template -> Line, and select the line style to be drawn in the line

 template drawing panel. 

 

Figure: Line Template 
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Figure: Line Type Panel 

② Draw in the view window. The drawing method is the same as that of polylines, 

and the line style is the style of the selected line template. If 3D drawing is used, th

e selected line style cannot be displayed. 

 

 

Figure: Drawing Effect of Line Style 
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2.4.9 Display 

2.4.9.1 Vector to Top 

Function Description: 

Display the vectors in the view on top of all data without affecting the actual positio

n of the vectors. 

Operation Steps: 

Click Vector -> Display -> Vector Top to switch the On/Off status of vector to top, 

which is enabled by default. 

 

Figure: Vector to Top 
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Figure: Effect of Vector to Top 

 

Figure: Effect of Vector Not to Top 

2.4.10 Building Extraction 
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2.4.10.1 Plane Extraction 

2.4.10.1.1 Track 

Function Description: 

Click on the point cloud to automatically track the direction of one edge of the plane

 contour, and you can switch to manual drawing mode in the right-click menu. 

Operation Steps: 

① First perform point cloud slicing, click Base -> Slicing -> Horizontal. 

 

 

Figure: Horizontal Slice 

② In the view, click a point on the point cloud to adjust the slice to an appropriate 

thickness and position to display a clear and complete building contour point cloud. 

 

Figure: Building Contour Point Cloud 
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③ Click Vector -> Extraction -> Planar Extraction -> Track. 

 

Figure: Track 

④ In the view, click two points to determine the direction of the first edge of the plane 

contour. 

⑤ In the view, click a point to determine the direction of the next edge, which intersects 

with the previous edge, and continue drawing as needed. 

⑥ In the view, press Enter to end, or right-click and select "Ok" to complete the plane 

contour drawing. The default drawn vector is closed. If you need to draw a non-closed 

vector, uncheck "Auto-Close" in the right-click menu. 

⑦ During the drawing process, right-click and select "Undo" or use the shortcut key U to 

undo one point. 

⑧ The default is "2D Drawing". In track mode, the vector elevation is always constrained 

to the same plane during both "2D Drawing" and "3D Drawing". 
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Figure: Right-Click in Track Mode 

2.4.10.1.2 Rect Extraction 

Function Description: 

Draw a polygon to select point clouds and automatically extract building plane 

contours. 

Operation Steps: 

Load the point cloud and perform point cloud slicing, click Base -> Slicing -> 

Horizontal. 
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Figure: Horizontal Slice 

In the view, click a point on the point cloud to adjust the slice to an appropriate thic

kness and position to display a clear and complete building contour point cloud. 

 

Figure: Building Contour Point Cloud 

 Click Vector -> Building Extraction -> Planar Extraction -> Rect Extraction. 

 

Figure: Frame Selection 

In the view, click to draw a polygon to frame the building contour point cloud, and t

he software will automatically identify and extract the building plane contour line. 

During the drawing process, right-click and select "Undo" or use the shortcut key U t

o undo one point. 
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Figure: Right-Click in Rect Extraction 
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Figure: Result of Rect Extraction 

2.4.10.2 Create Facade 

2.4.10.2.1 Select 

Function Description: 

Select vector lines or facade proxy lines to create facade views. 

2.4.10.2.1.1 Create Facade - Four-View 

Operation Steps: 

① Click Vector -> Extraction -> Create Facade -> Select. 
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Figure: Selection 

① In the view, click to select a closed vector, and the create facade dialog box will 

pop up. 

 

Figure: Create Facade Dialog Box 

 

① Select "Four-View" for "View Mode". 

① Select "Select Line Segment" or "Specify Direction" to confirm the front view, then

 click "Ok". 

(1) If "Select Line Segment" is selected, after confirmation, you need to select an edg

e on the selected closed vector as the front view direction to generate facade proxy li

nes and activate the facade view. The facade view displays the facade point cloud an

d vector data from the current perspective. Click the first button in the horizontal tool
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bar, and click "Front, Left, Back, Right" in the drop-down box to switch and display 

the facade view point clouds from different directions. 

 

Figure: Four-View Facade Proxy Line 

(2)If "Specify Direction" is selected, after confirmation, you need to draw two points i

n the view to determine a line segment, confirm the front view direction according to

 the arrow direction to generate facade proxy lines and activate the facade view. The 

facade view displays the front view point cloud. Click the first button in the horizont

al toolbar, and click "Front, Left, Back, Right" in the drop-down box to switch and d

isplay the facade view point clouds from different directions. 
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Figure: Specify Direction 
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Figure: Facade View - Four-View 

2.4.10.2.1.2 Create Facade - Multi-View 

Operation Steps: 

① Click Vector -> Extraction -> Create Facade -> Select. 

 

Figure: Select 

 

② In the view, click to select a closed vector, and the create facade dialog box will pop up. If 

a non-closed vector is selected, this dialog box will be skipped and the facade view will be 

created directly. 

 

 

Figure: Create Facade Dialog Box 
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③ Select "Multi View" for "View Mode" and click "OK" to generate facade proxy lines and 

activate the facade view. The facade view displays the facade view point cloud of the first 

segment of the vector. Click the first button in the horizontal toolbar, and click different 

numbers in the drop-down box to switch and display the facade view point clouds of different 

edges. 

 

Figure: Multi-View Facade Proxy Line 
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Figure: Facade View - Multi-View 

 

Note: 

① If an facade proxy line is selected, it will directly enter the facade view 

corresponding to the selected facade proxy line. 

② The data display range of the current facade view is the range covered by the 

corresponding facade proxy line in the 3D view from the top view. 

③ To recreate the facade, you can delete the original facade proxy line and then 

select the original vector again to create the facade view. 

2.4.10.2.2 Draw 

Function Description: 

Draw vector lines to create facade views. 

Operation Steps: 

① Click Vector -> Extraction -> Create Facade -> Drawing. 
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2.4.10.2.2.1 Create Facade - Four-View 

Operation Steps: 

① Click Vector -> Extraction -> Create Facade -> Draw. 

 

Figure: Draw 

 

① In the view, click to draw a polyline, which is in vertex mode by default. You ca

n right-click to switch to other drawing modes. After checking "Auto-Close" or right-c

licking "Close", end the drawing, and the vector line is closed, and the create facade 

dialog box will pop up. 
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Figure: Right-Click in Drawing 
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Figure: Create Facade Dialog Box 

① Select "Four-View" for "View Mode". 

① Select "Select Line Segment" or "Specify Direction" to confirm the front view. 

(1) If "Select Line Segment" is selected, after confirmation, you need to select an edg

e on the drawn closed vector as the front view direction to generate facade proxy lin

es and activate the facade view. The facade view displays the front view point cloud. 

Click the first button in the horizontal toolbar, and click "Front, Left, Back, Right" in 

the drop-down box to switch and display the facade view point clouds from different 

directions. 
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Figure: Four-View facade Proxy Line 

(2) If "Specify Direction" is selected, after confirmation, you need to draw two points 

in the view to determine a line segment, confirm the front view direction according t

o the arrow direction to generate facade proxy lines and activate the facade view. The

 facade view displays the front view point cloud. Click the first button in the horizon

tal toolbar, and click "Front, Left, Back, Right" in the drop-down box to switch and 

display the facade view point clouds from different directions. 
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Figure: Specify Direction 
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Figure: Facade View - Four-View 

  2.4.10.2.2.2- Create Facade-Multi-View 

Operation Steps: 

① Click Vector -> Extraction -> Create Facade -> Draw. 
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Figure: Draw 

 

① In the view, click to draw a closed vector, and the create facade dialog box will p

op up. If a non-closed vector is drawn, this dialog box will be skipped and the facad

e view will be created directly. 

 

Figure: Create Facade Dialog Box 

 

① Select "Multi-View" for "View Mode" and click "OK" to generate facade proxy lin

es and activate the facade view. The facade view displays the facade view point clou

d of the first segment of the vector. Click the first button in the horizontal toolbar, a
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nd click different numbers in the drop-down box to switch and display the facade vie

w point clouds of different edges. 

 

Figure: Multi-View Facade Proxy Line 
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Figure: Facade View - Front View 

Note: 

① The data display range of the current facade view is the range covered by the 

corresponding facade proxy line in the 3D view from the top view. 

② After closing the create facade dialog box, the drawn vector line will not be retained. 

2.4.10.3 Facade Project 

Function Description: 

By selecting the facade proxy line, flattem and copy all vector elements in the releva

nt facade to the 3D view. 

Operation Steps: 

① Click Vector -> Extraction -> Facade Project. 
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Figure: Facade Project 

 

① Click the facade proxy line in the 3D view, and all vectors in the facade willappe

ar at the mouse cursor in preview state. 

① Click a point with the mouse to determine the base point position for facade flatte

ning and complete the facade flattening operation. 

 

Figure: Effect of Facade Flattening 

2.5 Help 

2.5.1 Help 

① Click Help -> Help, and the help document can be opened after clicking. 
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Figure: Help 

2.5.2 License 

Function Description: 

Click to view the software license status or activate it. If the software is not authoriz

ed or the authorization has expired, the license manager interface will pop up directly 

when starting the software. The software supports three registration methods: registratio

n code, Pre-code, and dongle. 

Operation Steps: 

① Click Help -> License to pop up the license manager dialog box, where you can v

iew the current software license status. 
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Figure: License 

 

Figure: License Manager Interface 

2.5.2.1 Activation via Registration Code 

Function Description: 

Activate the software by entering the registration code, supporting offline activation. 

Operation Steps: 
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① Click Help -> License to pop up the license manager dialog box, or when there is

 no permission, start the software and the license manager dialog box will pop up dir

ectly. 

① On the authorization activation page of the license manager dialog box, copy the "

Machine ID" and send it to the software service personnel to obtain the registration c

ode. 

 

Figure: Copy Machine ID 

① Select "Registration Code" and enter the obtained registration code in the input bo

x. 

 

Figure: Enter Registration Code 

Click "Activate". After the activation is successful, you can start the software and use 

the functions of the authorized module normally. 
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2.5.2.2 Activation via Pre-Code 

Function Description: 

Activate the software by entering the Pre-code. When the machine is connected to the

 Internet, the Pre-code can be used directly for activation. When not connected to the 

Internet, you need to convert the Pre-code to a registration code through other method

s, and then activate it through the "Activation via Registration Code" method. 

Operation Steps: 

① Click Help -> License to pop up the license manager dialog box, or when there is

 no permission, start the software and the license manager dialog box will pop up dir

ectly. 

① On the authorization activation page of the license manager dialog box, copy the "

Copy" to copy machine ID and send it to the software service personnel to obtain the

 Pre-code. 

 

Figure: Copy Machine ID 

① Select "Pre-Code" and enter the obtained Pre-code in the input box. 
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Figure: Enter Redemption Code 

① Click "Activate". After the activation is successful, you can start the software and 

use the functions of the authorized module normally. 

Note: 

Internet connection is required when activating by entering the Pre-code. 

2.5.2.3 Activate Dongle 

Function Description: 

After inserting the dongle, activate it by entering Register Code/Pre Code to obtain so

ftware authorization. 

Operation Steps: 

Insert the unauthorized dongle and launch the registry manager, the license dialog will

 pop up. 
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Figure: Registry Manager 

Dong can be activated via either registration code or pre-code. 

(1) Activation via registration code: On the authorization page of the Register Manage

r dialog box, select "Register Code" and enter the obtained registration code in the in

put box. Click "Activate"; once the activation success prompt appears, you can launch 

the software and use the functions of the authorized module normally. 

(2) Activation via pre-code: On the authorization page of the Register Manager dialog 

box, select "Pre-Code" and enter the obtained pre-code in the input box. Click "Activ

ate"; once the activation success prompt appears, you can launch the software and use

 the functions of the authorized module normally. 

2.5.3 Update 

Function Description: 

Click the "Update" button to check for the latest version. If the current software is n
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ot the latest version, you can use this function to update the software to the latest ve

rsion. 

Operation Steps: 

If the current version is not the latest, clicking the "Update" button will bring up the 

update content dialog box. If the current version is already the latest, no dialog box 

will pop up, and the output window will display the message: "You are using the late

st version." 

2.5.4 Version 

Function Description: 

Click "Version" to check the currect version information. 

Operation Steps: 

① Click Help -> License->Version, pop up Coprocess 2025 version information, copyri

ght description and download link of latest version. 

 

Figure: Version 
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Figure: Version Information 
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3.Introduction to Operation Process 

3.1 Basic Data Processing 

3.1.1 Add Data 

This chapter introduces the addition methods of different data in CoProcess 2025. The 

software supports loading and displaying point cloud data, vector data, raster data, and

 3D model data. 

3.1.1.1 Add Point Cloud 

Point cloud data supports adding different formats such as las, laz, hpc, and codata. 

Method 1: Click "Import" in the "Base" function panel, select the point cloud data to 

be opened. 

 

Figure：Open PointCloud 

 

Method 2: In the folder, select the data to be added, hold down the left mouse butto

n, drag it to the software interface, and release the mouse to add. 

Method 3: In Project Manager, select the Point Cloud node, right-click, select Open P

oint Cloud, add the point cloud data to be loaded. 
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Figure：RightMenu-Open PointCloud 

In the Project Manager list, select the corresponding data, right-click, and youcan perform 

operations such as "Close", "Redirect", "Open File Directory", etc. 

3.1.1.2 Add vector Data 

Vector data addition: 

Vector data supports adding different formats such as dwg and dxf. 

Method 1 In the folder, select the data to be added, hold down the left mouse butto

n, drag it to the software interface, and release the mouse to add. 

Method 2: In Project Manager, select the Vector node, right-click, select Open Vector, 

add the vector data to be loaded. 
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Figure：Open Vector 

In the Project Manager list, select the corresponding data, right-click, and you can perform 

operations such as "Close", "Redirect", "Open File Directory", etc. 

3.1.1.3 Add Raster Data 

Raster data addition: 

Supports adding images, DEM, etc., with formats including jpg, jpeg, tif, tiff, bmp, pn

g, etc. 

Method 1: In the folder, select the data to be added, hold down the left mouse butto

n, drag it to the software interface, and release the mouse to add. 

Method 2: In Project Manager, select the Raster node, right-click, select Open DEM o

r Image, add the raster data to be loaded. 
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Figure：Open Raster 

 

In the Project Manager list, select the corresponding data, right-click, and you can perform 

operations such as "Close", "Redirect", "Open File Directory", etc. 

 

 

3.1.1.4  Add Model Data 

Model data addition: 

Model data supports adding model data in .osgb format by adding files and folders. 

Method 1: In the folder, select the data to be added (.osgb or folder), hold down the 

left mouse button, drag it to the software interface, and release the mouse to add. 

Method 2: In Project Manager, select the Model node, right-click, select Open OSGB 

Model or Open OSGB Dir, add the model data to be loaded, and click confirm. (Wh
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en selecting a folder, you can select it to the OSGB or Data level) 

 

Figure：Open OSGB 

In the Project Manager list, select the corresponding data, right-click, and you can perform 

operations such as "Close", "Redirect", "Open File Directory", etc. 

 

3.1.1.5 Multi-View Settings 

Multi-view settings: 

The software supports multi-view loading and browsing of data, and supports up to 4 

views to be displayed simultaneously. 

Operation method: 

Add view: Click "New" in the menu bar, and a new empty view will be added to th

e software interface. Click continuously to continue creating new views, up to four. 
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Figure：New View 

 

Add data: In the Project Manager list, select the data to be added to View 2, hold d

own the left mouse button, drag it to the interface of View 2, and release the mouse. 

At the same time, the added data will be displayed in the list of View 2. 

 

Figure：Add data to view 

Or in the folder where the file is located, select the data to be added and drag it to 
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View 2 to complete the data addition, and the added data will be displayed in the Pr

oject Manager list and the list of View 2. 

 

Figure：Add data to ViewNode 

In the view list, select the corresponding data and right-click to center, show/hide, re

move, etc. 

3.1.2 Point Cloud Merging 

This chapter introduces how to merge point clouds in CoProcess 2025. Currently, whe

n data in formats such as las, laz, and codata are added to CoProcess 2025, the soft

ware will automatically convert the data format to hpc. 

① Add point cloud data, and add the point cloud data (two or more) to be merged t

o the software. 

① Click "Export" in the Base module, and select the point cloud data to be merged i

n the data list. The selected data will be highlighted in orange. 
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Figure：Export PointCloud 

 

① Parameter settings, including sampling settings, sampling rate, export format, and m

erge into a single file. Here, we can set the parameters according to actual needs. For

 example, when the sampling setting is random sample, the corresponding sampling ra

te can be set; when it is grid sample, the grid space can be set. At the same time, t

he exported point cloud format can be set to hpc or las, and when las is selected, th

e corresponding version can be set. 

When merging point clouds, it is critical to check "Merge File". 
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Figure：Merge data to single file 

① Export path selection. After confirming the point clouds to be merged and the exp

ort parameters, click "Ok", select the export path, and name the exported point cloud. 

Then the point cloud merging operation can be completed. 

 3.1.3 Point Cloud Clipping 

This chapter describes how to perform point cloud clipping operations in the software,

 including general clipping and slice clipping, and exporting the clipped point cloud. 

Point cloud clipping: In the Base module, use the selection function to select the poin

t cloud to be clipped or retained. The selected point cloud will be displayed in red. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

383 

 

Figure：Select Cropping Selection 

Select Inner Clipping in Clipping to complete the point cloud clipping. 

Slice clipping: The software also supports point cloud clipping after slicing. 

① Use the slicing function to slice the point cloud. Here, use vertical slicing to cut o

ut the point cloud. 

 

Figure：Vertcial Slice 

 

① Use the selection function to select the point cloud to be deleted, then use Inner C

lipping to delete the selected point cloud. 
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Figure：Select Cropping Selection 

① After deleting the noise points in the current slice, you can click Forward or Back

ward in the slice settings on the right to adjust the position of the slice, and repeat s

tep ① to continue deleting noise points. 

 

Figure: Internal Cropping 

① Click Export to complete the export of the clipped point cloud. 

① Slice point cloud export: The export of slice point cloud is slightly different from t

hat of clipped point cloud. The slice point cloud export only exports the point cloud 

after the current slice.  

3.1.4 Precision Check 
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This chapter introduces how to perform precision check in CoProcess 2025. The softw

are supports precision check of point clouds, Mesh models, orthophotos, and other dat

a. 

For precision check, after adding data to the software, click "Precision" in Check to p

op up the precision check function panel. 

 

 

Figure: accuracy inspection 

Import the control point file. The coordinates of the control point file must be consist

ent with the coordinate system of the added data. 
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Figure: Choose Control-point File 

In the import interface, first select the delimiter to ensure that the imported control po

ints are separated by columns, then specify the attributes of each column (point name,

 X, Y, Z coordinates, etc.), and click "Open" after setting to add data. 
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Figure: Specify Column Property 

 

Figure: Add Control-points 

After importing control points, set the point type according to the actual inspection re

quirements. It can be set to elevation point, plane point, and 3D Point, corresponding 

to elevation inspection, plane inspection, and elevation and plane inspection respectivel

y. 

Set the plane RMSE limit and elevation RMSE limit. If exceeding the limit, it will b

e displayed in yellow or red in the control point list. 

① If only elevation inspection is needed, after setting all point types to elevation poin

ts, use the elevation matching function to quickly match elevation points. Check the e

levation point checkbox and click Match. 
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Figure: Match 

After the matching is completed, in the control point list, Match_X, Match_Y, and Ma

tch_Z display the corresponding values of the matched points, as well as the correspo

nding elevation differences. 
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Figure: Match Result 

Click Export Report to output the result report. 

① For plane and 3D point (plane and elevation) inspection, if plane or 3D point insp

ection is required, after setting the type of control points, point picking operation is r

equired to confirm the matching points. 

Click the "Mark" function button to activate the point picking function. In the control 

point list, select the control point to be picked, right-click, locate, and jump to the vi

cinity of the control point. 
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Figure: Jump to the control point position 

Then click the left mouse button on the corresponding position on the point cloud, m

odel, or orthophoto to pick the point. After point picking is completed, the coordinate

s of the matching point and the differences in XY and elevation are displayed in the 

control point list. At the same time, the matching point is displayed at the point picki

ng position (Points prefixed with "M" are matching points). 

If the position of the picked point is incorrect during point picking, you can continue 

picking points to overwrite the previous matching points. If a certain point is not to b

e inspected, you can right-click and delete the matching point. Perform point picking 

operations on all control points in turn. 

After point picking is completed, select the corresponding required RMSE calculation 

method, click Preview to view the preview result, or directly click Export Report to o

utput a PDF report. 
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3.2 Planar Drawing 

Planar drawing is generally used to draw planar vector results of buildings based on i

ndoor point cloud data. The general processing flow is as follows: 

 

 

Figure: Plane Drawing Process 

3.2.1 New Drawing 

Before formally drawing planar elements, it is necessary to create a new drawing. The

 purpose of creating a new drawing is to store all the elements in this drawing. 

Click "New" in the Vector menu bar, select the storage path, name the drawing, and 

click "Save" to complete the creation. 
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Figure: New Drawing 

After creating a new drawing, right-click and activate the drawing. At this point, the 

small icon in front of the corresponding drawing will be highlighted, indicating an act

ivated state. 

 

Figure: Set Active 

Activate the drawing. After creating a new drawing, it is necessary to activate the dra

wing so that the subsequently drawn elements will be saved in the corresponding acti

vated drawing. 
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 3.2.2 Create Layer 

After the drawing is created, it is necessary to create different element layers accordin

g to the elements to be collected in the current data, such as walls, windows, doors, 

annotations, etc. 

In the Vector menu bar, click the Layer button, and click New Layer in the Layer M

anager panel. 

 

Figure: Create Layer 

After creating a new layer, double-click the layer name to modify it, and click the co

lor to modify the layer color to distinguish different elements. 
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Figure: Modify Layer Color 

3.2.3 Point Cloud Slicing 

Before formally collecting planar elements, it is necessary to slice the added point clo

ud data to better view and reference when drawing planar elements. 

In the Base menu bar, click the Horizontal Slice function. The cursor turns into a kni

fe shape, indicating that the function is activated. Click the left mouse button on the 

point cloud data to be horizontally sliced to slice. 

 

Figure: Horizontal Slice 

Slice adjustment: Hold down "Ctrl" button and scroll the wheel to adjust the height o

f the slice. Hold down the Shift key and scroll the wheel to adjust the thickness of t

he slice. Or adjust the maximum and minimum values of the slice and the slice thick

ness in the slice settings panel to adjust the slice. 
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Figure: Slice Setting 

The main purpose of slice adjustment is to obtain clear and complete planar contour i

nformation, which is convenient for element collection. During collection, the slice can

 be dynamically adjusted continuously, and the ultimate goal is to facilitate element dr

awing. 

3.2.4 Planar Element Drawing 

Planar Element drawing includes walls, windows, doors, annotations, etc. For easy vie

wing, the view can be set to 2D in the right view settings. At this time, the data can

 only be panned and rotated, not flipped. 
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Figure: 2D View 

Wall drawing: Before drawing, select the current layer as the element to be drawn in 

the layer menu bar. Here, to draw a wall, select the layer as Wall. 

 

Figure: Set wall layer as current layer 

For regular wall structures, you can use the right-angle mode for drawing. Click the d

rop-down button of Polyline in the menu bar and select Right Angle Mode. 
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Figure: Right-Angle Mode 

Start drawing on the point cloud. You can turn off point cloud snapping in the lower 

right corner when drawing, and try to draw along the center of the point cloud. Whe

n needing to turn, the software will automatically turn at a right angle. 

 

Figure: Right-Angle Mode 

 

Double-click the left mouse button at the end of the drawing, or right-click and select

 "Ok" to end the drawing. 
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Figure: Finishing Drawing 

Window drawing: Window drawing is similar to wall drawing. Before drawing, switch 

the layer to the Window layer. Use Vertex Mode in Polyline (the window here is irre

gular). When drawing, the first point of the window snaps to the endpoint of the pre

vious wall, and then continue drawing. 
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Figure: Vertex Mode 

When it is necessary to switch the drawing mode during drawing, you can right-click 

and switch the polyline mode. For example, in this case, you can switch from Vertex 

Mode to Arc Mode to start drawing arcs and complete the window drawing. 
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Figure: Switch to Arc Mode 

Door feature : In the Vector menu bar, click Block in Template, select the door templ

ate, and confirm the position of the door with three points. 

 

Figure: Arc Mode 
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Figure: Drawing door 

 3.2.5 Add Annotation Features 

Addition of annotation features: 

Before annotation, you can set the annotation style, including text, unit, precision, etc. 

Here, set the precision to two decimal places. Click Apply. 
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Figure: Set dimension style 

 

Aligned dimension: Click the drop-down button of Dimension and select Aligned Dim

ension to start annotating on the drawn elements. 
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Figure: Drawing Align-Dimension 

Area dimension: For a closed 2D area, you can directly select the inside of the close

d area to calculate the area. 

 

Figure: Drawing Area Dimension 

Drawing Arrangement 

After drawing the elements, it is necessary to arrange the drawing, including the outp

ut of tables, files, and the output of the drawing frame. 

For table drawing, first draw the number of rows and columns of the table according 

to the content to be filled in the table. Use line drawing and offset functions in the s

oftware to draw the table. 
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Figure: Drawing Table 

Fill in the table content: Use the Text function to fill in the corresponding informatio

n in the table. 

Click the Text function, create the starting point, direction, and size of the text in thr

ee points, and then enter the text. 
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Figure: Drawing Text 

Drawing Frame: Use the Rectangle drawing function to frame the icon and the drawn 

vector, then use the Offset function to offset a rectangle to complete the drawing fra

me. 

 

Figure: Fill Table 
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3.3 Facade Drawing 

Facade drawing is generally used to draw facade information of buildings, including d

ifferent elements such as walls, windows, doors, steps, and annotations. 

The data processing flow is as follows: 

 

Figure: Facade Drawing Process 

3.3.1 New Drawing 

Before formally drawing planar elements, it is necessary to create a new drawing. The

 purpose of creating a new drawing is to store all the elements we draw in this draw

ing. 

Click "New" in the Vector menu bar, select the storage path, name the drawing, and 

click "Save" to complete the creation. 
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Figure: New Drawing 

After creating a new drawing, the new drawing will be displayed in both the Project 

Manager list and the View ① list. And the icon in front of the name is gray, it need

s to be activated. 

Activate the drawing. After creating a new drawing, it is necessary to activate the dra

wing so that the subsequently drawn elements will be saved in the corresponding acti

vated drawing. 

 

Figure: Drawing-unactived 

In the Project Managemer panel, right-click and activate the drawing. At this time, the

 small icon before the corresponding drawing is highlighted, indicating an activated st

ate. 
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Figure: Set drawing active 

 

 

 

3.3.2 Create Layer 

After the drawing is created, it is necessary to create different element layers accordin

g to the elements to be collected in the current data, such as walls, windows, doors, 

steps, annotations, etc. 

In the Vector menu bar, click the Layer button, and click New Layer in the Layer M

anager panel. 
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Figure: Create New Layer 

After creating a new layer, double-click the layer name to modify it, and click the co

lor to modify the layer color to distinguish different elements. 

 

Figure: Modify Layer Color 

3.3.3 Point Cloud Slicing 

Before formally collecting planar elements, it is necessary to slice the added point clo

ud data to better view and reference when drawing planar elements. 

In the Base menu bar, click the Horizontal Slice function. The cursor turns into a kni

fe shape, indicating that the function is activated. Click the left mouse button on the 

point cloud data to be horizontally sliced to slice. 



CHCNAV Navigation File Number CHC -YHSC-021-2025 

CoProcess 2025 User Manual Version  

 

410 

 

Figure: Horizontal Slice 

Slice adjustment: Hold down the "Ctrl" and scroll the wheel to adjust the height of t

he slice. Hold down the Shift key and scroll the wheel to adjust the thickness of the 

slice. Or adjust the maximum and minimum values of the slice and the slice thicknes

s in the slice settings panel to adjust the slice. 
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Figure: Slice Setting 

The main purpose of slice adjustment is to obtain clear and complete planar contour i

nformation, which is convenient for element collection. During collection, the slice can

 be dynamically adjusted continuously, and the ultimate goal is to facilitate element dr

awing. 

3.3.4 Planar Range 

Before drawing facade elements, it is necessary to draw a planar range first. The soft

ware will automatically cut the facade data according to the planar range to facilitate 

us to draw facade elements. 

Select the layer as Plane before drawing. 

After horizontal slicing is completed, in the Vector menu bar, click the drop-down but
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ton of Polyline and select Right Angle Mode (for regular buildings) to draw the plana

r range. 

During drawing, you can turn off point cloud snapping in the lower right corner to fa

cilitate drawing. Try to draw the planar range line in the center of the slice point clo

ud. When drawing surface elements, you can turn on Auto-Close. 

 

Figure: Rigjt Menu 

 3.3.5 Facade Element Drawing 

After drawing the plane, click the Create Facade function in the Vector menu bar to 

generate facade point clouds. After clicking "Create Facade", select an edge on the ve

ctor as front view 

For buildings with regular structures, you can select Four-View; for buildings with co

mplex structures, you can select Multi-View. 

Click "Ok", and then select a edge of the vector as the front view. 
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Figure: Right-Angle Mode 

After creating the facade view, the software automatically loads the front view facade 

point cloud into the facade view. 

Adjustment of the point cloud range in the facade view: The yellow part displayed in 

the planar range contour is the range cut by the current view. You can adjust the cutt

ing thickness in the facade view to adjust the slice range to ensure that the complete 

point cloud data is displayed in the facade view. 

 

Figure: Four View 

After the facade view point cloud slicing is set appropriately, start drawing facade ele
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ments. 

First, switch the layer to Wall, and then start drawing wall elements. 

In the Vector menu bar, click the drop-down button of Polyline and select Right Angl

e Mode to start drawing the facade range. The starting point of the drawing can start 

snapping from the endpoint of the planar range. 

 

Figure: Facade View 

Window drawing: After drawing the wall, you can draw window elements. 

In the Vector menu bar, select Rectangle Drawing, and draw rectangles in two-point o

r three-point mode to represent windows. 
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Figure: Set window-layer as current layer 

Window array, batch processing: For identical windows, you can use the array functio

n to generate other windows in batches. 

After drawing one window element, select the current window and click the Array fu

nction. 

 

Figure: Window-Array 

Modify the row spacing, column spacing, and number of rows and columns in the pa

rameter panel. 
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Modify the row spacing: manually adjust the plus and minus buttons of the row spaci

ng to adjust the row spacing until it is in the appropriate position on the graph. Or c

lick the adjustment button to manually adjust the row spacing. 

Modify the column spacing: The modification of column spacing is the same as that 

of row spacing, which can be adjusted manually by plus or minus or by manual trans

lation. 

 

Figure: Set array parameter 

 

After setting the row and column spacing reasonably, set the corresponding number of

 rows and columns. You can manually enter the corresponding number of rows and c

olumns in the parameter panel, or manually pull the diagonal to confirm the number 
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of rows and columns. 

Click Confirm after setting to complete the array processing of window elements. 

 

Figure: Set array parameter 

Step elements: Switch the layer to Step, and then use Right Angle Mode to start dra

wing steps. 
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Figure: Right Angle Mode 

Door element drawing: Switch the layer to door, and then use Rectangle to start draw

ing doors. 

 

Figure: Drawing door 
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Drawing of adjacent facade: After drawing the elements of one facade, you can click 

the view selection in the facade view to switch to other views and repeat the element

 collection work. 

 

Figure: Choose View 

You can also adjust the slice thickness to ensure that the completed point cloud data 

is displayed in the facade view. 
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Figure: Set facade-view options 

At the same time, you can also display the elements of adjacent facade in the current

 view to facilitate snapping during drawing and ensure data consistency. 

 

Figure: Facade unfolding 
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 3.6.6 Add Annotation Information 

After drawing the facade elements, you can flatten the facade elements to the plane, and then 

perform operations such as annotation and hatch. 

Facade Project: After drawing the facade elements, close the facade view, click the Facade 

Project function in the menu bar, select the facade proxy line to be flattened, and then select 

the corresponding position to flatten the facade. 

 

Figure: Facade Flat 

Add dimension, which can include aligned dimensions, area dimensions, etc. 

Before dimension, you can set the dimension style, including text, unit, precision, etc. 

Here, set the precision to two decimal places. Click Apply. 
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Figure: Dimension Style 
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Figure: Drawing Align-Dimension 

Aligned dimension: Click the drop-down button of Dimension and select Align

ed Dimension to start annotating on the drawn elements. 

 

Figure: Drawing Area-Dimension 

Area dimension: For a closed 2D area, you can directly select the inside of the close

d area to calculate the area. Click directly inside the closed 2D area to perform area 

dimensioning. 

Hatch: For elements such as walls, for easy identification, you can set hatch for the e

lements. Click the hatch button in the menu bar, select Pick Internal Point, select a h

atch style, and click inside the element to be filled to complete the hatch. 

If the displayed style is unreasonable after filling, you can adjust the hatch pattern rat

io in the property panel until the style is displayed reasonably. 
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Figure: Facade Flat 
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Figure: Drawing fill pattern 

3.3.7 Drawing Arrangement 

After drawing the elements, it is necessary to arrange the drawing, including the output of 

tables, files, and the output of the drawing frame. 

For table drawing, first draw the number of rows and columns of the table according to the 

content to be filled in the table. Use line drawing and offset functions in the software to draw 

the table. 

Fill in the table content: Use the Text function to fill in the corresponding information in the 

table. 
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Click the Text function, create the starting point, direction, and size of the text in three points, 

and then enter the text. 

 

 

Figure: Create Text 

Drawing frame: Use the Rectangle drawing function to frame the icon and the drawn 

vector, then use the Offset function to offset a rectangle to complete the drawing fra

me. 
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Figure: Fill Table 
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4.Shortcut Functions and Shortcut Keys  

4.1 Platform Shortcut Keys 

 

Shortcut Keys Shortcut Functions Remarks 

Esc Exit Current Functions Used Globally 

 

 


